Bug 231056 - dependency check for default install options takes too long
dependency check for default install options takes too long
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 15:29 EST by John Poelstra
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 16:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2007-03-05 15:29:36 EST
Description of problem:
I'm doing standard installs of Fedora from the DVD media.  Could we add some way
to skip or reduce the time of the dependency check routine if default install
options are selected and the install is being performed from install media with
a correct MD5 of SHA1?

In other words if I do an install from a FC6 or FC7T2 DVD and check the boxes
for "Office & Productivity" and "Software Development" and make NO other changes
to the underlying selections it takes exactly 4 minutes and 14 seconds to
determine that the dependencies are met.  That seems like a long time to sit and
stare at the screen when the installer could know that the check does not need
to be performed.  

It seems to me that for installs from a fixed source like a DVD, the dependency
checks should be run when the ISOs are built or once during testing... not every
time you do a default install. 

This is also a performance hit for automated testing scenarios where default
install options are selected for a distribution that must first be installed
before the tests are performed.
Comment 1 Jeremy Katz 2007-03-05 15:58:15 EST
And what do you do about languages?  As they can and do change the package set.
 Or different kernels... they could have different deps too.

This is entirely the wrong answer.  If dep checking is slow, then we should work
on making it faster as we can, not paper over the problem with nonsense like
this.  Luckily, there's some work under way to do so.  But not going to fix this
explicitly
Comment 2 John Poelstra 2007-03-05 16:42:59 EST
Okay... then how about making this a tracker bug for making dep checking faster?
Comment 3 Jeremy Katz 2007-03-05 16:46:50 EST
Because that exists as a separate bug and is being tracked upstream in yum. 
This isn't something that we're just going to fix for anaconda. 

Note You need to log in before you can comment on or make changes to this bug.