Bug 231073 - liferea goes unresponsive and must be killed
liferea goes unresponsive and must be killed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 17:26 EST by Jonathan Corbet
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.19-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 11:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Corbet 2007-03-05 17:26:27 EST
Description of problem:

liferea hangs

Version-Release number of selected component (if applicable):

liferea-1.2.7-2.fc7

How reproducible:

Very, for those who wait.  Leaving it running overnight always brings about the
problem; it will happen a few times over the course of the day as well.


Steps to Reproduce:
1. Start liferea
2. Wait
3.
  
Actual results:

The window becomes completely unresponsive to events (including expose).  I ran
it by hand and saw a big pile of messages reading:

  (Gecko:7394): GThread-CRITICAL **: g_cond_timed_wait_posix_impl: assertion
`end_time.tv_nsec < G_NSEC_PER_SEC' failed

Expected results:

No hang

Additional info:
Comment 1 Brian Pepple 2007-03-07 10:13:35 EST
Hmmm, been unable to reproduce this on my machine.  It's probably something
specific with x86_64.
Comment 2 Kevin Fenzi 2007-05-06 01:18:28 EDT
Just to update this with info I have found: 

- It does only seem to happen with x86_64. I have installed the i386 version of
the package and it's been fine. 

- Upstream has a bug for this where the maintainer says he can't reproduce it: 
http://sourceforge.net/tracker/index.php?func=detail&aid=1675822&group_id=87005&atid=581684
(Thanks for filing that Brian)

- I installed the debuginfo and ran under gdb, but the stack trace wasn't too
usefull looking to me: 

#0  0x0000003ab82c71c6 in poll () from /lib64/libc.so.6
#1  0x0000003abca2fe7e in g_free () from /lib64/libglib-2.0.so.0
#2  0x0000003abca3033a in g_main_loop_run () from /lib64/libglib-2.0.so.0 
#3  0x0000003ac2b2d0d3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0 
#4  0x000000000043ce08 in main (argc=2, argv=0x7fff63f38308) at main.c:286

We might want to make a note in the release notes for f7 about this bug and
suggest x86_64 liferea users install the i386 version?

It's pretty much unusable on x86_64 here... 

Comment 3 Brian Pepple 2007-05-06 15:09:05 EDT
(In reply to comment #2) 
> We might want to make a note in the release notes for f7 about this bug and
> suggest x86_64 liferea users install the i386 version?
> 
> It's pretty much unusable on x86_64 here... 
> 

Yeah , liferea on x86_64 has consistently been a problem.  None of the
backtraces I've received have been much help in trying to track down the bugs. 
If I had my choice though, I would exclude it from even being built for x86_64
since upstream barely even supports it.

Regardless, like you suggested I'll look at adding a note in the PackageNotes on
the wiki later today.
Comment 4 Kevin Fenzi 2007-05-06 15:28:27 EDT
I added a note to 
http://fedoraproject.org/wiki/Docs/Beats/PackageNotes
already. Feel free to change/edit/move it. 

Comment 5 Andrew Clayton 2007-06-06 10:51:50 EDT
I have to say, that I've not had a problem with liferea under x86_64 (FC6 and
now F7, liferea-1.2.10c-3.fc7.x86_64). This is my work machine and I'm only
using it for RSS feeds from our wiki though, so not heavy use.
Comment 6 Jonathan Corbet 2007-06-22 09:36:26 EDT
FWIW, with current (late June) rawhide, the problem would appear to have gone
away.  It used to reliably happen within a few hours; I've not seen it for over
a week.  This is with liferea-1.2.16b-1.fc8 on x86_64...I'm cautiously
optimistic that somebody has managed to fix this issue.
Comment 7 Kevin Fenzi 2007-06-22 12:43:09 EDT
ok, I'll be brave and try the x86_64 version here again. 
liferea-1.2.15b-1.fc7.x86_64

Will report back in a bit. For me it usually locks up in about 10-15min. 
Comment 8 Brian Pepple 2007-06-27 14:34:29 EDT
(In reply to comment #7)
> ok, I'll be brave and try the x86_64 version here again. 
> liferea-1.2.15b-1.fc7.x86_64
> 
> Will report back in a bit. For me it usually locks up in about 10-15min. 

Kevin, how did that go?
Comment 9 Kevin Fenzi 2007-06-27 15:04:59 EDT
Well, good and bad. ;) 

I have been using the 1.2.15b-1 x86_64 version here fine for a while.
It looks like it's fixed there. 

However, this morning I upgraded to the 1.2.17 version in updates-testing, and
the problem is back. Only in a few minutes I can get it to spike to 100% cpu on
both my cores and stop responding. ;( 
Comment 10 Fedora Update System 2007-07-05 15:14:06 EDT
liferea-1.2.19-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Kevin Fenzi 2007-07-05 15:16:01 EDT
1.2.19.x86_64 has been working fine here for a few days now. This one looks like
a winner here. 
Comment 12 Fedora Update System 2007-07-11 11:19:26 EDT
liferea-1.2.19-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.