Bug 231088 - openarena menu entry's tooltip not HIG compliant
openarena menu entry's tooltip not HIG compliant
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openarena (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-05 20:12 EST by petrosyan
Modified: 2009-09-21 16:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 13:41:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2007-03-05 20:12:25 EST
Description of problem:
According to GNOME HIG
http://developer.gnome.org/projects/gup/hig/2.0/desktop-integration.html#menu-item-tooltips
menu item tooltips should be phrased as an imperative verb.

# Phrase the tooltip as an imperative verb, for example "design", "write" or
"check".

openarena's menu tooltip is not phrased as a verb. It is: "First person shooter"

Version-Release number of selected component (if applicable):
openarena-0.6.0-4.fc7
Comment 1 Michał Bentkowski 2007-03-06 11:59:13 EST
Which one do you think would best fit?
 - "Score frags to win the game"
 - "Frag enemy players and score points"
or
 - "Try to be the arena master" ;-)
Comment 2 petrosyan 2007-03-06 12:41:33 EST
I like "Frag enemy players and score points" better.
Comment 3 Michał Bentkowski 2007-03-06 16:55:49 EST
(In reply to comment #2)
> I like "Frag enemy players and score points" better.

Fine then, I'll set this when the next release is out.

BTW. When I took a look at my installed packages, it turned out that a lot of 
packages do not have tooltips phrased as an imperative verb. Are you going to 
report bugs related with other applications? Or propose it as the new Packaging 
Guideline?
Comment 4 petrosyan 2007-03-06 20:41:57 EST
I don't know. I just decided to file bugs for all packages that I have installed
that are not HIG compliant. But I think creating a new packaging guideline is a
very good idea. Since you are in the packaging business could you move this up
the line and propose it? It would be nice to have consistent menu entries.
Comment 5 Wart 2007-03-07 13:44:11 EST
(In reply to comment #1)
> Which one do you think would best fit?
>  - "Score frags to win the game"
>  - "Frag enemy players and score points"
> or
>  - "Try to be the arena master" ;-)

Or add 'Play a' to the beginning:

'Play a first person shooter'.  This tactic would apply to most of the games in
the menus.
Comment 6 Michał Bentkowski 2007-03-07 14:02:59 EST
(In reply to comment #5)
> 'Play a first person shooter'.  This tactic would apply to most of the games 
in
> the menus.

IMO this is not "the most important tasks users can accomplish with your 
application" but the task user can accomplish by clicking the menu item.

Note You need to log in before you can comment on or make changes to this bug.