Bug 231159 - up2date --register fails
Summary: up2date --register fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration   
(Show other bugs)
Version: unspecified
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
: 231158 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-06 16:13 UTC by HTC Systems Admin
Modified: 2007-10-24 02:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 16:25:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description HTC Systems Admin 2007-03-06 16:13:03 UTC
Description of problem:

When running up2date --register, I'm able to complete the registration and 
submit it to RHN, but upon exit this is displayed:

[root@localhost ~]# up2date --register
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 749, in main
    if cfg['useRhn'] and not up2dateAuth.getLoginInfo():
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 161, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 114, in login
    raise f
xmlrpclib.Fault: <Fault -31: '\nError Message:\n    Service not enabled for 
system profile: "HTC-CMS"\nError Class Code: 31\nError Class Info: \n     This 
system does not have a valid entitlement for Red Hat Network.\n     Please 
visit https://rhn.redhat.com/network/systems/entitlements.pxt\n     or login at 
https://rhn.redhat.com, and from the "Systems" tab,\n     select "System 
Entitlements" to enable RHN service for this system.\nExplanation: \n     An 
error has occurred while processing your request. If this problem\n     
persists please enter a bug report at bugzilla.redhat.com.\n     If you choose 
to submit the bug report, please be sure to include\n     details of what you 
were trying to do when this error occurred and\n     details on how to 
reproduce this problem.\n'>


Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST 2005 
i686 i686 i386 GNU/Linux

How reproducible:
Run 'up2date --register'

Steps to Reproduce:
1. 'up2date --register'
2. 'up2date --list'
3.
  
Actual results:
same

Expected results:
Should work

Additional info:

Comment 1 Bret McMillan 2007-03-06 16:25:51 UTC
Please ensure you have sufficient channel & system entitlements.

Previously, we allowed people to register systems w/out either of those, and it
led to user confusion when they got no useful service.

If you *do* have active channel & system entitlements, please reopen the bug.

Comment 2 Bret McMillan 2007-03-06 16:26:53 UTC
*** Bug 231158 has been marked as a duplicate of this bug. ***

Comment 3 HTC Systems Admin 2007-03-06 17:11:46 UTC
We have the following contract on this system:

Contract #1046339 Feb. 27, 2007 Feb. 26, 2008     
Red Hat Enterprise Linux ES (v.4 L3 for x86, AMD64, and Intel EM64T) 
   subscription number : 4b44-dde4-8d51-662b  

This was taken from the subscriptions section of the Red Hat Account details.


Note You need to log in before you can comment on or make changes to this bug.