Bug 231179 - NOARP flag - bonding module.
NOARP flag - bonding module.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-06 12:45 EST by AndY
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 15:44:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description AndY 2007-03-06 12:45:37 EST
Description of problem:

I use bonding module:
********
~> cat /proc/net/bonding/bond0 
Ethernet Channel Bonding Driver: v2.6.3 (June 8, 2005)

Bonding Mode: fault-tolerance (active-backup)
Primary Slave: None
Currently Active Slave: eth2
MII Status: up
MII Polling Interval (ms): 500
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth1
MII Status: up
Link Failure Count: 1
Permanent HW addr: xx:xx:xx:xx:xx:a2

Slave Interface: eth2
MII Status: up
Link Failure Count: 1
Permanent HW addr: xx:xx:xx:xx:xx:a1
*******
When I check flags for both eth1 and eth2 interfcases I can not see NOARP flag
:/ Is this correct behavior? As far as I know not :/
*******
~> /sbin/ifconfig 
bond0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:A2  
          inet addr:y.y.y.y  Bcast:y.y.y.y  Mask:y.y.y.y
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:307720960 errors:0 dropped:0 overruns:0 frame:0
          TX packets:181273244 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3734283934 (3.4 GiB)  TX bytes:1442379585 (1.3 GiB)

eth1      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:A2  
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:220513553 errors:0 dropped:0 overruns:0 frame:0
          TX packets:131254652 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3459738145 (3.2 GiB)  TX bytes:2498148179 (2.3 GiB)
          Interrupt:233 

eth2      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:A2  
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:87207407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50018592 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:274545789 (261.8 MiB)  TX bytes:3239198702 (3.0 GiB)
          Interrupt:50 

*******

Version-Release number of selected component (if applicable):
*****
Ethernet Channel Bonding Driver: v2.6.3 (June 8, 2005)
*****
~> cat /etc/redhat-release 
Red Hat Enterprise Linux ES release 4 (Nahant Update 4)
*****
*****

How reproducible:

There are no special steps for it. Just installed and configured.  

Actual results:
No NOARP flag on the interface(s).

Expected results:
NOARP flag on the interface(s).


Additional info:
I was searching for information if NOARP flag should be set in 2.6.3 verion of
bond module but I was founf nothing :/ I'm using in the old environment oldest
version of bond module and there is NOARP flag for not active interface.
Comment 1 AndY 2007-03-08 07:06:00 EST
Any one ?
Is this a normal situation :/ ?
Comment 2 John W. Linville 2007-04-09 16:40:38 EDT
Are you actually observing a problem?  Or are you just lonely for the NOARP 
flag? :-)
Comment 3 Andy Gospodarek 2007-04-09 16:57:31 EDT
Is the lack of NOARP a change from RHEL4 Update 3?
Comment 4 AndY 2007-04-12 04:01:51 EDT
> Are you actually observing a problem?  

Yes, I can still observe this situation :/

> Or are you just lonely for the NOARP flag? :-)

I hope that I'm not alone :) 
Comment 5 John W. Linville 2007-04-12 09:08:33 EDT
Perhaps you misunderstand the question.  What I mean to ask is "does bonding 
work for you"?  And, "is there some reason you think that having NOARP would 
make it work better"?
Comment 6 AndY 2007-04-13 09:24:39 EDT
We had some problem with losing some packages on interfaces in our servers (in
few machines, not only one). That's why we susspected that problem could be with
bonding because we found this starnge for us behaviour with this NOARP flag.

In this moment we solved our problem in the other way and it seems like it was
no problem with this flag. So, in this case answers for you questions are:

> What I mean to ask is "does bonding work for you"? 

Yes. It works.

> is there some reason you think that having NOARP would make it work better

In this moment, I don't think so.

Note You need to log in before you can comment on or make changes to this bug.