Bug 231245 - Dell XPS M1210 laptop webcam doesn't work out of the box
Dell XPS M1210 laptop webcam doesn't work out of the box
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-06 17:58 EST by William Lovaton
Modified: 2008-04-14 18:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 18:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2007-03-06 17:58:49 EST
Description of problem:
I want to use my laptop webcam with Fedora but it doesn't work because there is
no drivers for it in the stock kernel.  I think this is a more or less popular
laptop and I think this webcam should be supported and configured automatically
out of the box.

Right now I am running Fedora 7 Test 2 from the liveCD and I have no way to
install it permanently so it's going to be a little bit difficult to make tests.

My hardware specs are as follows (lspci):
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA
Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400]
(rev a1)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 0a)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)


lsusb shows the following:
Bus 002 Device 004: ID 046d:08c6 Logitech, Inc.


I can install the UVC driver on the native Ubuntu Linux on this laptop and it
sort of works (only with Ekiga).
http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk/

Why this driver isn't included in the kernel already? is there any (better)
alternative?

I have been investigating a little bit before posting this bug report and I find
this ones very useful (I don't know for sure if they are related):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208398
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209112


Please, tell me what else can I do to help solve this problem.
Comment 1 Bug Zapper 2008-04-03 19:38:22 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 William Lovaton 2008-04-08 21:41:55 EDT
I'm closing this bug.

According to the Linux Driver Project (as I said in the original report) this
web cam is supported by an out of tree driver:
http://www.linuxdriverproject.org/twiki/bin/view/Main/OutOfTreeDrivers#Video_Input

The driver is UVC:
http://linux-uvc.berlios.de/

There seems to be a real interest in pushing this upstream but there are some
issues with V4L2 keeping the driver from hitting mainline:
http://lists.berlios.de/pipermail/linux-uvc-devel/2007-August/001930.html

So I think it is not really useful to keep this bug open, it is best to wait
until the issues are resolved and Fedora can get the driver directly from upstream.
Comment 3 Chuck Ebbert 2008-04-10 15:24:11 EDT
The UVC drivers are in Fedora 8 and rawhide...
Comment 4 William Lovaton 2008-04-13 11:21:33 EDT
Great! I didn't know that.  It works great, I tested it on a Live USB Rawhide
system (the snapshot from April 4).

There are minor glitches but it is related to driver it self not with Fedora. 
In fact, this is the best this webcam have ever worked on Linux.

Chuck, if you consider there is no other issues you can close this bug report.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.