Bug 231269 - Kernel panic during DHCP, Realtek RTL8168/8111 in NB Asus A67
Kernel panic during DHCP, Realtek RTL8168/8111 in NB Asus A67
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-07 01:50 EST by Tomas Prochazka
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 13:25:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cumulative r8169.c patch (40.02 KB, patch)
2007-04-01 19:38 EDT, Jost Diederichs
no flags Details | Diff

  None (edit)
Description Tomas Prochazka 2007-03-07 01:50:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Description of problem:
When Fedora try connect to Internet via DHCP, fedora freeze, only keyborad blinking (kernel panic). When I put off ethernet kable, fedora start correctly. When I put in cable after it and try activate eth0, fedora freeze.

I have Notebook ASUS A6T, which has Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC.

I can send some log.

Version-Release number of selected component (if applicable):
tested in kernel-2.6.20-1.2966.fc7.x86_64.rpm and kernel-2.6.20-1.2949.fc7.x86_64.rpm

How reproducible:
Always


Steps to Reproduce:
1. Only install and run Fedora Core Test 2 on Asus A6T Notebook with Realtek RTL8168/8111 ethernet card.


Actual Results:


Expected Results:


Additional info:
Comment 1 Vaclav "sHINOBI" Misek 2007-03-07 08:10:35 EST
I have the similar problem (same test release and kernel versions). My HW is
also x86_64 Realtek RTL8168/8111 (both cards on motherboard), motherboard MSI
K9A Platinum. r8168 module is loaded without problems, but it crashes during
network startup. I'm using fixed IP addresses and with this setting kernel
crashes everytime when this network controller is set to ONBOOT=yes.
I'm booting the kernel with pci=nomsi option (as the SATA controller is
unavailable without this).
Comment 2 Jost Diederichs 2007-03-23 10:57:27 EDT
I appear to have the same issue. r8169.ko module appears to load but kernel
panic on ifup. 
mad64 system with nvidia chipset. r8169 controller on PCI card.
kernel-2.6.20-1.3003.fc7.x86_64
Comment 3 Jost Diederichs 2007-03-25 20:47:07 EDT
With kernel 2.6.20-1.3017.fc7.x86_64 the problem has disappeared. 
According to the kernel changelog, no_hz was disabled, and may be that mitigated
the problem. 
Comment 4 Vaclav "sHINOBI" Misek 2007-03-26 06:35:44 EDT
On my system the problem still persists even with 2.6.20-1.3017.fc7.x86_64. With
the latest kernels it's possible to ifup interface without oops, but ONLY
without network cable plugged to the interface. With the cable it oopses every time.
Comment 5 Jost Diederichs 2007-03-28 02:06:16 EDT
Correction,
that the problem was fixed with kernel 2.6.20-1.3017.fc7.x86_64 was an
overstatement - the kernel still oopses once a day. 
Now with kernel 2.6.20-1.3023.fc7.x86_64 the symptoms are back, just as before:
Trying to ifup the device always leads to kernel panic. 
Comment 6 Jost Diederichs 2007-04-01 19:38:09 EDT
Created attachment 151399 [details]
Cumulative r8169.c patch

I found this bug on kernel.org:
http://bugzilla.kernel.org/show_bug.cgi?id=6807
In comment #23 it references a patchkit available at:
http://www.fr.zoreil.com/linux/kernel/2.6.x/2.6.21-rc4/r8169-20070316
it patches r8169.c of kernel source 2.6.20-1.3036.fc7 cleanly. 
So far the results look good. I have done some stress testing and so far not
been able to panic the kernel. 
I'll attach a cumulative patch I built. 
Vaclav, can you test this, too? If you can still get the 1.3036 build you can
simply download the module r8169.ko (x86_64) from
http://the-diederichs.com/downloads/r8169.ko.
Comment 8 Jost Diederichs 2007-04-03 02:52:13 EDT
success.
tested it again with build 1.3036 and more extensively with build 1.3038. 
no problems, thanks
Comment 9 Will Woods 2007-04-03 12:14:49 EDT
Tomas,

Can you try the current rawhide kernel (kernel-2.6.20-1.3040.fc7) and confirm
that it fixes your problem?
Comment 10 Tomas Prochazka 2007-04-05 03:17:26 EDT
I tested with kernel-2.6.20-1.3040.fc7.x86_64.rpm
And stil the same :-( Kernel panic.

I also tried put out cable during booting and activate eth0 manualy after 
system start, the same result.
Comment 11 Jost Diederichs 2007-04-05 10:05:24 EDT
Did you apply the patch from comment 7?
To save some time you can try the compiled module (for build 1.3040.x86_64) from
here:
http://the-diederichs.com/downloads/r8169.ko
Comment 12 Tomas Prochazka 2007-04-05 11:04:08 EDT
No, I used oficial rpm.
Now, I tried yours r8169.ko module and DHCP is working with it.
Great!
Comment 13 Dave Jones 2007-04-23 13:25:35 EDT
this should be fixed in current builds. Please reopen if this isn't the case.

Note You need to log in before you can comment on or make changes to this bug.