Bug 231274 - Anacanda: various translation troubles
Summary: Anacanda: various translation troubles
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-07 09:25 UTC by Milan Kerslager
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-07 16:26:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2007-03-07 09:25:54 UTC
The dialog for adding iSCSI target has untranslateable buttom "_Add target"
(textw/partition_text.py:1705).

The type of newly created partition (ext3, physical volume (LVM), software RAID,
swap vfat) are not translateable (iw/partition_dialog_gui.py:302).

There are a lot of untranslated texts in the dialogs even they have non-fuzzy
translations in the current CVS tree on i18n.redhat.com:/usr/local/CVS. This
seems that current anaconda's POT file is not pushed to the
i18n.redhat.com:/usr/local/CVS or something similar. Could do you plese sync it?
I tested current development tree (ie. 3/6/2007).

Comment 1 Jeremy Katz 2007-03-07 16:26:53 UTC
(In reply to comment #0)
> The dialog for adding iSCSI target has untranslateable buttom "_Add target"
> (textw/partition_text.py:1705).

I don't see that string listed anywhere in the source... although I see a couple
of other strings right there.  So marked them.

> The type of newly created partition (ext3, physical volume (LVM), software RAID,
> swap vfat) are not translateable (iw/partition_dialog_gui.py:302).

This has historically been done on purpose since real filesystems (ext2, ext3,
vfat) aren't actually translatable strings.  The addition of physical volume and
software RAID there make things a little bit more fuzzy.  But translating them
would unfortunately lead to some substantial breakage with things like
kickstart.  This entire area is up to be reworked for Fedora 8 at which point,
we can revisit things.

> There are a lot of untranslated texts in the dialogs even they have non-fuzzy
> translations in the current CVS tree on i18n.redhat.com:/usr/local/CVS. This
> seems that current anaconda's POT file is not pushed to the
> i18n.redhat.com:/usr/local/CVS or something similar. Could do you plese sync it?

It's more just that the pot file doesn't get automatically regenerated.  I've
done so now.  I've done the pot file and am refreshing the pos now.  And I'll
send a mail to fedora-trans-list on some ways to help with this.



Note You need to log in before you can comment on or make changes to this bug.