Bug 23130 - groff fails to format document correctly
groff fails to format document correctly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-02 05:04 EST by Rene Uittenbogaard
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 08:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rene Uittenbogaard 2001-01-02 05:04:47 EST
The problem can be seen using the following command:

zcat /usr/share/man/man8/pump.8.gz | groff -man | gv -

The postscript code generated contains the following line, which has
correct syntax, but produces incorrect output:
(COMMAND-LINE OPTIONS)72 266.4 Q F0(lB lB lB lfCW lfCW l.)108 278.4 Q
Comment 1 Rene Uittenbogaard 2001-01-04 09:02:39 EST
correction: groff -man should of course be groff -mandoc:

zcat /usr/share/man/man8/pump.8.gz | groff -mandoc | gv -
Comment 2 Florian La Roche 2001-04-03 05:16:39 EDT
Seems to work fine with the current rpm packages from rawhide. If you still see
problems,
please reopen this bug or a new bug with information on how to reproduce this.
Comment 3 Rene Uittenbogaard 2001-04-03 07:57:06 EDT
which "current packages" exactly are you referring to? At the moment, i am using
the following versions:

gv-3.5.8-11
groff-1.16.1-4 (from rawhide)
pump-0.8.3-2

Ghostview cannot be the problem, as it correctly displays the postscript
document. I have already shown you a command which you can use to reproduce the
problem. Additionally, the problem is reproducible also with nroff:

zcat /usr/share/man/man8/pump.8.gz | nroff -man | less

PUMP(8)            Linux Administrator's Manual           PUMP(8)


NAME
       pump  -  configure  network  interface  via  BOOTP or DHCP
       protocol

SYNOPSIS
       /sbin/pump [-krRsd?] [-c ARG] [-h hostname] [-i iface] [-l
       hours] [--lookup-hostname] [--usage]

DESCRIPTION
       pump  is a daemon that manages network interfaces that are
       controlled by either the DHCP or BOOTP protocol.

       While pump may be started manually, it is normally started
       automatically   by   the  /sbin/ifup  script  for  devices
       configured via BOOTP or DHCP.

       Once pump is managing an interface, you can  run  pump  to
       query the status of that interface.  For example,
       /sbin/pump -i eth0 --status
       will print the current status of device eth0.

COMMAND-LINE OPTIONS
       lB     lB     lB     lfCW    lfCW    l.     switch    long
       option    description

Linux                   December 07, 1999                       1





()                                                             ()


()     -c   --config-file=ARG   Configuration file to use instead
       of                                          /etc/pump.conf
       -h   --hostname=hostname Hostname        to        request
       -i   --interface=iface   Interface  to configure (normally
       eth0)  -k   --kill    Kill   daemon   (and   disable   all
       interfaces)  -l   --lease=hours  Lease time to request (in
       hours)      --lookup-hostname   Always  look  up  hostname
       and   domain   in   DNS  -r   --release Release  interface
       -R   --renew   Force     immediate      lease      renewal
       -s   --status  Display           interface          status
       -d   --no-dns  Don't          update           resolv.conf
       -?   --help    Show        this        help        message
            --usage   Display brief usage message

LOGGING
       Pump logs a good deal of information to syslog, much of it
       at  the DEBUG level. If you're having trouble, it's a good
       idea to turn up syslog's logging level.

(etc.) there are more errors in the same formatted output, but the first error
is the line just below "COMMAND LINE OPTIONS" which is not formatted correctly.
I cannot, however, tell if the problem is in the nroff source (pump.8.gz) or the
parsing performed by nroff/groff as i cannot interpret nroff source.


Comment 4 Rene Uittenbogaard 2001-04-03 08:00:22 EDT
compare the mentioned nroff output to the output given by "man pump":

PUMP(8)            Linux Administrator's Manual           PUMP(8)

NAME
       pump - configure network interface via BOOTP or DHCP protocol

SYNOPSIS
       /sbin/pump  [-krRsd?]  [-c  ARG]  [-h  hostname]  [-i  iface] [-l hours]
[--lookup-
       hostname] [--usage]

DESCRIPTION
       pump is a daemon that manages network interfaces that are controlled by
either  the
       DHCP or BOOTP protocol.

       While  pump  may  be  started manually, it is normally started
automatically by the
       /sbin/ifup script for devices configured via BOOTP or DHCP.

       Once pump is managing an interface, you can run pump to query the 
status  of  that
       interface.  For example,
       /sbin/pump -i eth0 --status
       will print the current status of device eth0.

COMMAND-LINE OPTIONS
       switch   long option           description

       ()                                                             ()

       -c       --config-file=ARG     Configuration file to use instead of
                                      /etc/pump.conf
       -h       --hostname=hostname   Hostname to request
       -i       --interface=iface     Interface to configure (normally eth0)
       -k       --kill                Kill daemon (and disable all interfaces)
       -l       --lease=hours         Lease time to request (in hours)
                --lookup-hostname     Always look up hostname and domain in DNS
       -r       --release             Release interface
       -R       --renew               Force immediate lease renewal
       -s       --status              Display interface status
       -d       --no-dns              Don't update resolv.conf
       -?       --help                Show this help message
                --usage               Display brief usage message

LOGGING
       Pump  logs  a good deal of information to syslog, much of it at the DEBUG
level. If
       you're having trouble, it's a good idea to turn up syslog's logging
level.

Comment 5 Florian La Roche 2001-04-03 08:09:18 EDT
use gtbl for tables, current groff rpms are also on
http://people.redhat.com/laroche/
Comment 6 Rene Uittenbogaard 2001-04-03 08:18:34 EDT
I see.

zcat /usr/share/man/man8/pump.8.gz | gtbl | groff -mandoc | gv -

this produces correct output. I was not aware of the need for gtbl.


Note You need to log in before you can comment on or make changes to this bug.