Bug 231389 - Latest autofs spits an error and exits
Latest autofs spits an error and exits
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-07 18:15 EST by Elliot Lee
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.1-0.rc3.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 12:33:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2007-03-07 18:15:34 EST
Description of problem:

When I 'cd /net/<hostname>', the automount process logs an error to syslog, and
aborts.

Problem occurs with autofs-5.0.1-0.rc3.23

autofs-5.0.1-0.rc3.16 was working for me.

The message in syslog is:

automount[13356]: do_mount_indirect: failed to get group info from getgrgid_r


When I attach gdb to the automount process, the traceback is:

#0  0x00002aaaab3221b5 in raise () from /lib64/libc.so.6
#1  0x00002aaaab323b20 in abort () from /lib64/libc.so.6
#2  0x00002aaaab35966b in __libc_message () from /lib64/libc.so.6
#3  0x00002aaaab3d2cdf in __chk_fail () from /lib64/libc.so.6
#4  0x00002aaaac0e8a5b in match_network (network=<value optimized out>) at
rpc_subs.c:1070
#5  0x00002aaaac0e8d70 in host_match (pattern=0x5555557b8720
"webapps1.rdu.lulu.com") at rpc_subs.c:1233
#6  0x00002aaaac0e8f58 in rpc_exports_prune (list=<value optimized out>) at
rpc_subs.c:1254
#7  0x00002aaaac0e4b0d in lookup_mount (ap=0x5555557a1ad0, name=0x5555557a2d00
"master1", name_len=7, 
    context=0x55555579ce40) at lookup_hosts.c:204
#8  0x0000555555566f93 in lookup_nss_mount (ap=0x5555557a1ad0,
name=0x5555557a2d00 "master1", name_len=7)
    at lookup.c:786
#9  0x00005555555601b9 in do_mount_indirect (arg=0x5555557a2c80) at indirect.c:887
#10 0x00002aaaaaccc305 in start_thread () from /lib64/libpthread.so.0
#11 0x00002aaaab3bf50d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

That traceback looks like malloc/free corruption of some sort.
Comment 1 Ian Kent 2007-03-07 21:51:00 EST
(In reply to comment #0)
> Description of problem:
> 
> When I 'cd /net/<hostname>', the automount process logs an error to syslog, and
> aborts.
> 
> Problem occurs with autofs-5.0.1-0.rc3.23

Can you update to autofs-5.0.1-0.rc3.25 and see if that fixes
it please.

Ian
Comment 2 Tomasz Kepczynski 2007-03-09 00:52:07 EST
I've seen this problem as well. My guess is that autofs takes
netgroup name as network or hostname. This only occurs on
some fileservers (netapp) which control access using both
netgroups and networks in export specification. For me it
looks like autofs expects netgrup to begin with @ sign, while
netapp does not have it. Also Solaris servers do not
show/expect @ in front of netgroup name.
As described in other bug, -hosts map does not work at all
in autofs-5.0.1-0.rc3.25.
Comment 3 Elliot Lee 2007-03-09 11:27:14 EST
What Tomasz said - the -hosts map doesn't work at all in .25.
Comment 4 Ian Kent 2007-03-29 04:46:57 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > 
> > When I 'cd /net/<hostname>', the automount process logs an error to syslog, and
> > aborts.
> > 
> > Problem occurs with autofs-5.0.1-0.rc3.23
> 
> Can you update to autofs-5.0.1-0.rc3.25 and see if that fixes
> it please.

Missed this.
I think this is resolved in autofs-5.0.1-0.rc3.26.
Can you check please.

Ian
Comment 5 Elliot Lee 2007-03-29 12:33:36 EDT
rc3.26 works great for me.

Note You need to log in before you can comment on or make changes to this bug.