Bug 231518 - Fix error handling in check_partition(), again
Fix error handling in check_partition(), again
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-08 14:59 EST by Eric Sandeen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:43:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (813 bytes, patch)
2007-03-08 15:10 EST, Eric Sandeen
no flags Details | Diff

  None (edit)
Description Eric Sandeen 2007-03-08 14:59:47 EST
The fixes that went in for 

Bugzilla Bug 210234: [RHEL5 BETA1] Patch - Fix error handling in
check_partition() and rescan_partitition()

have had 2 corrections since they went upstream, which should probably be pulled
back.  Those fixes are also slated for the backported patch for RHEL4 in bug 229709.

One change addresses the error return from rescan_partitions, which could
erroneously look like -EPERM when it should be -EIO.

The other addresses a possibly missed IO error in the check_partition error return.
Comment 1 Eric Sandeen 2007-03-08 15:10:58 EST
Created attachment 149618 [details]
patch

kernel.org is acting up, but I think this is the patch that needs to come back;
will confirm.
Comment 2 Eric Sandeen 2007-03-08 15:21:14 EST
http://www2.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.21-rc3/2.6.21-rc3-mm2/broken-out/check_partition-fix-error-check.patch

is part of it; the other change still needs to go upstream as near as I can tell.
Comment 4 RHEL Product and Program Management 2007-04-13 14:01:43 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 5 Don Zickus 2007-04-17 16:00:27 EDT
in 2.6.18-15.el5
Comment 8 errata-xmlrpc 2007-11-07 14:43:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.