Bug 231568 - [chewing] Look up table is showing candidates of previous look-up.
[chewing] Look up table is showing candidates of previous look-up.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libchewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
: i18n
Depends On: 220288
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-08 20:56 EST by Caius Chance
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 02:33:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2007-03-08 20:56:09 EST
+++ This bug was initially created as a clone of Bug #220288 +++

+++ This bug was initially created as a clone of Bug #218565 +++

Description of problem:


Version-Release number of selected component (if applicable):
RHEL5-Client-20061201.0
scim-1.4.4-39.el5
scim-chewing-0.3.1-10.el5

How reproducible:
always

Steps to Reproduce:
1.log in zh_TW locale
2.start gedit
3.ctrl-space to bring up Chewing IM and type 't' 
4.SPACE SPACE to bring up candiate window
5.click SPACE many times and then ESCAPE
6.click '.' many times
7.observe second last candidate is the candidate of previous look-up.
  
Actual results:
Such candidate should not be shown.

Expected results:
Lookup table should be cleared between every look-up.

Additional info:

-- Additional comment from cchance@redhat.com on 2006-12-17 23:10 EST --
Used libchewing test suite:

1. in upstream's svn trunk
2. make check
3. ./genkeystroke test.txt
4. then keyin

which shows libchewing works fine.

-- Additional comment from pm-rhel@redhat.com on 2006-12-20 09:01 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

-- Additional comment from cchance@redhat.com on 2007-01-02 03:04 EST --
Put this line in SetChoiceInfo() in choice.c:

memset( pci->totalChoiceStr, '\0', sizeof(char) * MAX_CHOICE * MAX_PHRASE_LEN *
MAX_UTF8_SIZE + 1);

before pci->nTotalChoice is zeroized.

-- Additional comment from cchance@redhat.com on 2007-01-02 03:09 EST --
Created an attachment (id=144623)
Patch file of this bug.

Clear previous data before populate ChoiceInfo data structure.

Bugs #220287 #220289 #220290 need separated patches to fix.

-- Additional comment from cchance@redhat.com on 2007-01-02 03:15 EST --
Patched, rebuilt, pending for QA.

-- Additional comment from cchance@redhat.com on 2007-01-02 19:54 EST --


*** This bug has been marked as a duplicate of 218565 ***
Comment 1 Caius Chance 2007-03-08 21:16:42 EST
Patched and pending for build.
Comment 2 Caius Chance 2007-03-08 21:31:28 EST
Built and pending for QA.
Comment 3 Jens Petersen 2007-10-02 02:33:56 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.