Bug 231635 - inputattach SERIO_RS232 breakage with recent kernels, patch available
inputattach SERIO_RS232 breakage with recent kernels, patch available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
David Lawrence
http://lkml.org/lkml/2006/2/8/121
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-09 12:18 EST by Ralph Siemsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: gpm-1.20.1-82.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 13:25:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralph Siemsen 2007-03-09 12:18:09 EST
Summary:
Included program "inputattach.c" needs to be updated to a more recent version.
http://lkml.org/lkml/2006/2/8/121

Longer Description:
The inputattach.c makes the call ioctl(SPIOCSTYPE) with argument SERIO_RS232
combined with other parameters.  This constant is defined in kernel header file,
but has changed value from 0x20000000 to 0x00000002 somewhat recently.  The new
value now conflicts with other parameters.  This results in inputattach being
unable to actually attach practically any external input device, because the
passed value will not match up with the tables in the kernel.

In the kernel the function serio_match_port() is where the problem is noticed. 
The comparison on the proto field always fails, because bits from the new value
of SERIO_RS232 interfere.
Comment 1 Fedora Update System 2007-04-02 12:24:59 EDT
gpm-1.20.1-82.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.