Bug 231704 - gnome-volume-control crashes
gnome-volume-control crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-10 07:43 EST by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: gnome-media-2.16.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-20 00:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2007-03-10 07:43:12 EST
Description of problem:
Calling gnome-volume-control crashes:
gnome-volume-control
shm.c: shm_open() failed: Permission denied
gnome-volume-control: pulsecore/memblock.c:481: pa_mempool_free: Assertion `p'
failed.
Calling stack:

Distribution: Fedora Core release 6 (Zod)
Gnome Release: 2.16.3 2007-01-31 (Red Hat, Inc)
BugBuddy Version: 2.16.0

System: Linux 2.6.19-1.2911.6.5.fc6 #1 SMP Sun Mar 4 16:41:13 EST 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 70101000
Selinux: Enforcing
Accessibility: Disabled

Memory status: size: 32956416 vsize: 0 resident: 32956416 share: 0 rss: 7299072
rss_rlim: 0
CPU usage: start_time: 1173530316 rtime: 0 utime: 6 stime: 0 cutime:5 cstime: 0
timeout: 1 it_real_value: 0 frequency: 3

Backtrace was generated from '/usr/bin/gnome-volume-control'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208170800 (LWP 4837)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00612402 in __kernel_vsyscall ()
#0  0x00612402 in __kernel_vsyscall ()
#1  0x00839cbb in waitpid () from /lib/libpthread.so.0
#2  0x03df9cf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00612402 in __kernel_vsyscall ()
#5  0x006e7d40 in raise () from /lib/libc.so.6
#6  0x006e9591 in abort () from /lib/libc.so.6
#7  0x006e138b in __assert_fail () from /lib/libc.so.6
#8  0x00ec884f in pa_mempool_free () from /usr/lib/libpulse.so.0
#9  0x00eb0298 in pa_context_unref () from /usr/lib/libpulse.so.0
#10 0x00201546 in gst_pulseprobe_get_values ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
#11 0x00201bf1 in gst_pulseprobe_free ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
#12 0x001ff67a in gst_pulsemixer_get_type ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
#13 0x004a90dc in g_object_unref () from /lib/libgobject-2.0.so.0
#14 0x002e2e6e in gst_object_unref () from /usr/lib/libgstreamer-0.10.so.0
#15 0x00af87b6 in gst_audio_default_registry_mixer_filter ()
   from /usr/lib/libgstaudio-0.10.so.0
#16 0x0804db5e in main ()

Thread 1 (Thread -1208170800 (LWP 4837)):
#0  0x00612402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00839cbb in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#2  0x03df9cf6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00612402 in __kernel_vsyscall ()
No symbol table info available.
#5  0x006e7d40 in raise () from /lib/libc.so.6
No symbol table info available.
#6  0x006e9591 in abort () from /lib/libc.so.6
No symbol table info available.
#7  0x006e138b in __assert_fail () from /lib/libc.so.6
No symbol table info available.
#8  0x00ec884f in pa_mempool_free () from /usr/lib/libpulse.so.0
No symbol table info available.
#9  0x00eb0298 in pa_context_unref () from /usr/lib/libpulse.so.0
No symbol table info available.
#10 0x00201546 in gst_pulseprobe_get_values ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
No symbol table info available.
#11 0x00201bf1 in gst_pulseprobe_free ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
No symbol table info available.
#12 0x001ff67a in gst_pulsemixer_get_type ()
   from /usr/lib/gstreamer-0.10/libgstpulse.so
No symbol table info available.
#13 0x004a90dc in g_object_unref () from /lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x002e2e6e in gst_object_unref () from /usr/lib/libgstreamer-0.10.so.0
No symbol table info available.
#15 0x00af87b6 in gst_audio_default_registry_mixer_filter ()
   from /usr/lib/libgstaudio-0.10.so.0
No symbol table info available.
#16 0x0804db5e in main ()
No symbol table info available.
#0  0x00612402 in __kernel_vsyscall ()


----------- .xsession-errors (427 sec old) ---------------------
Unable to connect to yum-updatesd.  Please ensure that the yum-updatesd 
package is installed and that the service is running.
Unable to connect to yum-updatesd.  Please ensure that the yum-updatesd 
package is installed and that the service is running.
Unable to connect to yum-updatesd.  Please ensure that the yum-updatesd 
package is installed and that the service is running.
Unable to connect to yum-updatesd.  Please ensure that the yum-updatesd 
package is installed and that the service is running.
Max failures exceeded, exiting now
** Message: Could not connect to power manager: Could not get owner of name
'org.gnome.PowerManager': no such name
** Message: Could not connect to power manager: Could not get owner of name
'org.gnome.PowerManager': no such name
shm.c: shm_open() failed: Permission denied
gnome-volume-control: pulsecore/memblock.c:481: pa_mempool_free: Assertion `p'
failed.


Version-Release number of selected component (if applicable):
gnome-media-2.16.1-2.fc6

How reproducible: Every time


Steps to Reproduce:
1.gnome-volume-control or Gnome-menu->System-Preferences->Volume-control
2.
3.
  
Actual results:
See above

Expected results:
Window of gnome-volume-control appears
Additional info:--
Comment 1 Bastien Nocera 2007-04-19 10:33:12 EDT
Looks like a problem with the Pulseaudio code. Could you please gather a
backtrace of the assertion following the instructions at:
http://fedoraproject.org/wiki/StackTraces
Comment 2 Joachim Backes 2007-04-20 00:40:42 EDT
in the meantime, gnome-media had been updated to gnome-media-2.16.1-2.fc6, and
this version is not buggy. I will close the report.
 

Note You need to log in before you can comment on or make changes to this bug.