Bug 231865 - Clock applet displays incorrect time for Evolution appointments (DST-related!)
Clock applet displays incorrect time for Evolution appointments (DST-related!)
Status: CLOSED DUPLICATE of bug 232113
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-12 13:27 EDT by Matthew Saltzman
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 11:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2007-03-12 13:27:03 EDT
Description of problem:
Clock applet display of Evoution appointments has wrong time.

Version-Release number of selected component (if applicable):
gnome-applets-2.16.0.1-12.fc6

How reproducible:
Always

Steps to Reproduce:
1. Enter an aapointment in Evolution for sometime between March 11 and April 1 2007
2. Open clock applet calendar and display the appointment date
3. Observe time of appointment
  
Actual results:
Appointment time dispayed is one hour later than appointment time in Evo calendar

Expected results:
Appointment time should agree with Evo calendar

Additional info:
Incorrect display occurs every year in the weeks between old and new DST changes.
Comment 1 David A. Cafaro 2007-03-12 14:13:25 EDT
I see this same inssue on my FC6 install.  Also of note is that the correct
"time" is displayed in the clock applet, it's just that evolution appointments
are shown in the pop up calendar display with an extra hour.

As mentioend, within evolution they are displayed at the correc time.
Comment 2 vfiend 2007-03-12 15:07:15 EDT
I have this same problem in FC6, appointments are displayed as starting one hour
later than they actually do while they look fine in Evolution itself. Though
you're right, it looks like they're the correct time again starting in April. Odd.
Comment 3 Ray Strode [halfline] 2007-03-12 15:21:27 EDT
what version of evolution-data-server do you guys have installed?
Comment 4 Ray Strode [halfline] 2007-03-12 15:22:04 EDT
Also, if you grab the version sitting in -updates-testing does the problem
magically fix itself?
Comment 5 Matthew Saltzman 2007-03-12 15:25:32 EDT
(In reply to comment #3)
> what version of evolution-data-server do you guys have installed?

FC6 latest production is evolution-data-server-1.8.3-2.fc6.
Comment 6 Matthew Barnes 2007-03-12 15:33:05 EDT
evolution-data-server-1.8.3-3.fc6 just hit FC6 Updates Final minutes ago.
This is the update with the DST changes.
Comment 7 Matthew Saltzman 2007-03-12 15:55:32 EDT
Just installed evolution-data-server-1.8.3-3.fc6 (from updates-testing,
apparently just before it moved).  It doesn not--repeat, does not--resolve this
issue.  Today's 4pm appt still shows as starting at 5pm.
Comment 8 Matthew Saltzman 2007-03-12 16:01:04 EDT
Sorry, I'm wrong.  My 4pm appt. has been moved to 5pm in Evo!  And it now shows
as 5pm in the clock applet as well.

I'm not sure I'd call it progress, but it does appear to resove this bug.
Comment 9 David A. Cafaro 2007-03-12 16:13:14 EDT
Wait, so your saying this update added an extra hour to all your appointments
(meaning you now have to go back and change them again to the correct time)?

If so did this also change the times for appointments in April and beyond to the
incorrect time?

This would not be a good solution if I have to go back and change all my
appointments back to the correct time after this update.  I'm specially worried
about reocurring appointments that extend from within march to april and beyond.

A little hesitant to try this update given the number of appointments I may have
to go back and correct.
Comment 10 vfiend 2007-03-12 16:32:08 EDT
Uh, if that's what the update does then it's worse than leaving this bug present..
Comment 11 Matthew Saltzman 2007-03-12 17:21:52 EDT
(In reply to comment #9)
> Wait, so your saying this update added an extra hour to all your appointments
> (meaning you now have to go back and change them again to the correct time)?

Right.

> 
> If so did this also change the times for appointments in April and beyond to the
> incorrect time?

No,only appts in the "gap" between new and old DST boundaries.


Comment 12 David A. Cafaro 2007-03-13 13:45:02 EDT
Have you checked to see if the same extra hour was applied to appointments in
the October 28th-November4th time frame (the other additional DST 1 week this year).

I haven't been able to test on a system of my own, not doing that update on my
FC6 workstation, to many appointments in that time frame to go back and change.
 Soon as I have a chance I can try it on a test system.
Comment 13 Matthew Saltzman 2007-03-13 13:59:33 EDT
(In reply to comment #12)
> Have you checked to see if the same extra hour was applied to appointments in
> the October 28th-November4th time frame (the other additional DST 1 week this
year).

Yes, it does, and to March 2008, etc. as well.
Comment 14 Matthew Saltzman 2007-03-13 14:07:40 EDT
One thing to add here:  The appts. that have been moved also display a pushpin
icon, which the other appts do not show.
Comment 15 vfiend 2007-03-13 20:06:13 EDT
He's right, I just got it from stable updates and it completely borked my
evolution calendar in addition to the clock applet. Why was this thing still
pushed to stable updates if people are complaining about it? You should really
pull this update as soon as possible, this is just really bad QA.

It's a good thing i made backups and found evolution-data-server-1.8.3-2.fc6 rpms.
Comment 16 vfiend 2007-03-13 20:09:23 EDT
At least I didn't have to manually restore my backed up data so this should be
easy to fix.
Comment 17 Matthew Saltzman 2007-03-13 20:35:04 EDT
No need to restore anything.  Backing off to evolution-data-server-1.8.3-2.fc6
returns all Evo calendar entries to the correct time but leaves the clock applet
times off by an hour, as in the original bug report.  The old version is still
in the Updates repo.

What I don't know is, what other apps are affected by having one or the other
version of evolution-data-server installed.
Comment 18 Matthew Barnes 2007-03-14 11:26:02 EDT

*** This bug has been marked as a duplicate of 232113 ***

Note You need to log in before you can comment on or make changes to this bug.