Bug 231867 - evolution calendar gets daylight savings time wrong
evolution calendar gets daylight savings time wrong
Status: CLOSED DUPLICATE of bug 232113
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-12 13:28 EDT by Wolfgang Rupprecht
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-data-server-1.8.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 13:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2007-03-12 13:28:51 EDT
Description of problem:

Evolution calendar gets changes to daylight savings time wrong.  An event that
was entered into the calendar to be at "11am" 2 months ago now shows up as being
scheduled for 12pm.  (What the heck is "12pm" anyway???  It should say 12noom or
12midnight)

Version-Release number of selected component (if applicable):

evolution-2.8.3-1.fc6

How reproducible:

I haven't tried to set the clock back and enter more events in the past to see
if they also come out 1 hr off of the expected time. 

Steps to Reproduce:
1. Go back in time till january 2007 and enter an event for March 12, 11am
2. on March 12 check your events and notice you are scheduled for 12pm (not 11am
as expected.)
3.
  
Actual results:
event time is changed to 12pm

Expected results:
event should display a time of 11am

Additional info:
It appears that the calendar resolves the time to "ctime" when the event is
entered.  Any subsequent redefinition of the DST rules will not cause the ctime
to be adjusted.  This is a classic case of where a late resolution of ascii time
 to ctime is desired.
Comment 1 Matthew Barnes 2007-03-12 13:32:04 EDT
Fixed in evolution-data-server-1.8.3-3.fc6, which is already available in Fedora
Updates Testing and should be pushed to Updates Final in the next day or so.
Comment 2 Wolfgang Rupprecht 2007-03-12 21:24:21 EDT
I just updated to evolution-data-server-devel.x86_64 1.8.3-3.fc6 and 
the problem is worse than before.

Before only the small callendar tool at the top-right showed the incorrect
times, now both the bigger evolution calendar (gotten via
applications->office->calendar)
and the small callendar tool both show the incorrect times.
Comment 3 Matthew Saltzman 2007-03-12 22:37:37 EDT
Well, the clock applet (the small calendar tool) shows the same time as the Evo
calendar, but the Evo calendar has changed the times of all appts in the gap
between new and old DST to one hour late, and each of the changed apps now shows
a "pushpin" icon that wasn't there before.

A few days ago, the Evo calendar was showing the times incrrectly, but after a
reboot late last week, they were corrected (but the clock applet was wrong). 
Now after updating evolution-data-server, I see the behavior above (which
Wolfgang also sees).
Comment 4 Need Real Name 2007-03-16 18:00:42 EDT
Me too (comments #2 and #3).

And, this is probably a dupe of 232113.
Comment 5 Matthew Saltzman 2007-03-17 17:00:00 EDT
Yes, I'm sure it is.

*** This bug has been marked as a duplicate of 232113 ***

Note You need to log in before you can comment on or make changes to this bug.