Bug 23188 - VIA Rhine driver broken and no support IRQ sharing
VIA Rhine driver broken and no support IRQ sharing
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-02 18:01 EST by Need Real Name
Modified: 2007-03-26 23:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-02 18:01:34 EST
I am having troubles with VIA Rhine driver and my DLink DFE-530TX NIC: it 
works only after warm reboot from Windows 98. If booting linux first, 
driver displays correct card, IRQ and mem address info but does not 
function. The second part of issue is that driver does not support IRQ 
sharing and I had to manually distribute IRQs among the PCI slots.

#via-diag -aem
via-diag.c:v2.04 7/14/2000 Donald Becker (becker@scyld.com)
 http://www.scyld.com/diag/index.html
Index #1: Found a VIA VT3065 Rhine-II adapter at 0xe400.
 Station address 00:00:00:00:00:00.
 Tx disabled, Rx disabled, half-duplex (0x0804).
  Receive  mode is 0x00: Unknown/invalid.
  Transmit mode is 0x00: Normal transmit, 128 byte threshold.
VIA VT3065 Rhine-II chip registers at 0xe400
 0x000: 00000000 00000000 00000804 00000000 00000000 00000000 00000000 
00000000
 0x020: 00000400 00000000 00000000 00000000 00000000 00000000 00000000 
00000000
 0x040: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
ffdfffff
 0x060: 00000000 00000000 00000000 0e09131f 00008100 08000080 02470000 
00000000
 No interrupt sources are pending (0000).
  Access to the EEPROM has been disabled (0x80).
    Direct reading or writing is not possible.
 ***WARNING***: No MII transceivers found!

Lookin forward to see a fix!
Cheers,
Alex
Comment 1 Jeremie Lacasse 2001-05-09 13:56:41 EDT
I have a bug that is similar that the one you have. My ethernet card and my 
scsi card can't have the same IRQ. I had to manually distribute IRQs among the 
PCI slots. It seems that this kernel doesn't support IRQ sharing, because with 
the same configuration with Red hat 7 (kernel 2.2) it work properly.
it is very strange.
Comment 2 Jeremie Lacasse 2001-05-09 13:58:24 EDT
sorry my kernel with the problem was 2.4 in red hat 7.1
thank you
Comment 3 Arjan van de Ven 2001-05-09 14:05:29 EDT
lacassej@teknor.com: the 2.4 kernel is supposed to share IRQ's just fine.
What exact hardware is this ?
Comment 4 Alan Cox 2003-06-05 19:11:14 EDT
No reply in 2 years

Note You need to log in before you can comment on or make changes to this bug.