Bug 231934 - vnc installer should always display IP address in addition to hostname
vnc installer should always display IP address in addition to hostname
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-12 23:04 EDT by eric magaoay
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 10:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2007-03-12 23:04:51 EDT
Description of problem:
VNC installer should always display the IP address that a VNC viewer should
connect to, since local DNS may not always be active and running, thus may not
be able to resolve the hostname given.

For example, the VNC server console should display:

The VNC server is now running.
Please connect to cozumel4:1 (192.168.3.27:1) to begin the install...

Version-Release number of selected component (if applicable):
anaconda 11.2.0.35-1.x86_64

How reproducible:
persistent

Steps to Reproduce:
1. select VNC new install
2. here is a sample kickstart file:
      vnc --password install
      url --url http://192.168.3.102/a/fed/x86_64/os
      network --device eth0 --bootproto dhcp --hostname fiji3
      lang en_US
      keyboard us
      rootpw install
      timezone America/New_York     
  
Actual results:
Starting VNC...
The VNC server is now running.
Please connect to cozumel4:1 to begin the install...

Expected results (last line above):
Please connect to cozumel4:1 (192.168.3.27:1) to begin the install...
Comment 1 Chris Lumens 2007-03-23 15:34:28 EDT
I've committed some code to display the IP address whenever we've got one,
though you're not going to see it until some fixes to the networking code get
committed as well.  I'm going to put this one in MODIFIED for now since there's
no way for me to test it with the outstanding networking bug.
Comment 2 eric magaoay 2007-03-23 17:20:40 EDT
I think the quick fix would be to simply run
   /sbin/ip route
and display the output to the console, 
right before starting VNC server start. 

Here is an example of what the output console will look like:
=======
192.168.3.0/24 dev eth1 proto kernel scope link src 192.168.3.20
default via 192.168.3.1 dev eth1
Starting VNC...
The VNC server is now running.
Please connect to cozumel4:1 to begin th install...
=======
I think many network admin installing through VNC will be able to guess which IP
to connect to (192.168.3.20) 
   vncviewer 192.168.3.20:1
when using the hostname (cozumel4) fails to resolved.
   vncviewer cozumel4:1

There is really no need to have additional sub-program to test whether a local
DNS server is enabled and functioning before displaying the IP address in place
of hostname. Remember, if hostname is defined in the kickstart file, there is
always a chance that the local DNS server may not be able to quickly update its
database in time to resolve the hostname to proper IP address... Just a thought. 
Comment 3 Joel Andres Granados 2007-05-07 10:51:49 EDT
I have just performed a vnc install on rawhide and this issue seems to be
resolved.  Anaconda gave the message that is described in the "Expected results"
section of the bug report.  I don't really know if the network code refered to
in comment #1 was commited, but apperantly the expected behavior has been achieved.

Note You need to log in before you can comment on or make changes to this bug.