Bug 232261 - Missing dist tag
Summary: Missing dist tag
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-14 16:28 UTC by Oliver Falk
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 17:22:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Falk 2007-03-14 16:28:58 UTC
Description of problem:
gcc is missing dist tag in release tag.

Additional info:
Index: gcc41.spec
===================================================================
RCS file: /cvs/dist/devel/gcc/gcc41.spec,v
retrieving revision 1.150
diff -r1.150 gcc41.spec
28c28
< Release: %{gcc_release}
---
> Release: %{gcc_release}%{?dist}

Comment 1 Jakub Jelinek 2007-03-14 17:13:36 UTC
Since when is the dist tag mandatory?  It has to my knowledge been always
optional...

Comment 2 Oliver Falk 2007-03-14 17:15:32 UTC
At least in extras it's mandatory and since core and extras will be merged, I
believe it should be added to all packages in core as well.

Comment 3 Jesse Keating 2007-03-14 17:20:22 UTC
(In reply to comment #2)
> At least in extras it's mandatory and since core and extras will be merged, I
> believe it should be added to all packages in core as well.

Dist tag is most certainly not mandatory in Extras, nor will it be in the merged
Core/Extras collection.  Please get your facts straight before filing a bunch of
invalid bugs.

Comment 4 Oliver Falk 2007-03-14 19:44:58 UTC
Sorry, Jesse, but last time I included a package to extras I was ask to add the
dist-tag, because it (is/)was mandatory. Maybe the reviewer got it wrong; Who
knows...

However.

I don't believe it's INVALID to add those bug-reports. Dist-tag simply makes
sense and it doesn't cost us anything, or hurts us in any way! At least to
distinct for which release the package was build for, it makes *MUCH* sense!

If *you* don't mind OK, but I would be happy if every package would have it!


Note You need to log in before you can comment on or make changes to this bug.