Bug 23238 - Can't "service httpd restart" with piranha-gui running
Summary: Can't "service httpd restart" with piranha-gui running
Status: CLOSED ERRATA
Alias: None
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha   
(Show other bugs)
Version: beta
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: Wil Harris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-03 18:00 UTC by Dale Lovelace
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 20:15:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Red Hat Bugzilla 2001-01-03 18:00:11 UTC
piranha-gui-0.5.3-9.i386.rpm

  If you have piranha-gui running, and you try to "service httpd restart"
apache stops, but then refuses to start back, assumedly because it finds a
"httpd" process already running, even though the "httpd" that is running is
not servicing port 80.

Comment 1 Red Hat Bugzilla 2001-01-03 20:15:44 UTC
Erk,..
Lets see,. the httpd init script /etc/rc.d/init.d/httpd
is what is actually being called so, what happens is that the restart option
just blindly does a stop and start
humm,..
so it's using "killproc http" which from the looks of it should use the
/var/run/httpd.pid file to work out which set of httpds it should be nuking. It
then goes on to blasts /var/lock/subsys/httpd /var/run/httpd.pid with an rm -f
for good measure.

Meanwhile the piranha-gui has run a second instance of httpd on port 3636,
however it stores it's info in
/etc/sysconfig/ha/logs/piranha-httpd.pid
/etc/sysconfig/ha/logs/piranha-httpd.lock
which is independant of the normal httpd

Hummm,... so much for reading the src code.
/etc/rc.d/init.d/httpd start uses the shell primitive daemon() to launch a new
httpd process
(found in /etc/rc.d/init.d/functions)

oh,.. right I see it's calling pidofproc which fails and then drops down to use
pidof which successfully sees the process and then terminates starting up a new
httpd umm
ok
 *thinking*

I'll see if I can get someone to look at that initscript function and find
something to do about it

But thats where it's dying. I suppose I'll have to work out a way of calling
httpd by the piranha-gui in such a way that pidof oesn't report it 8/

Phil
=--=

Comment 2 Red Hat Bugzilla 2001-05-16 23:22:41 UTC
This has been fixed and will appeared in upcoming RPMs


Note You need to log in before you can comment on or make changes to this bug.