Bug 232396 - [NetApp 5.1 bug] LVM doesn't work with iSCSI
Summary: [NetApp 5.1 bug] LVM doesn't work with iSCSI
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper   
(Show other bugs)
Version: 5.0
Hardware: All Linux
urgent
medium
Target Milestone: ---
: ---
Assignee: Mike Christie
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 217207
TreeView+ depends on / blocked
 
Reported: 2007-03-15 07:16 UTC by Ritesh Raj Sarraf
Modified: 2010-01-12 02:17 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 10:27:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ritesh Raj Sarraf 2007-03-15 07:16:02 UTC
Description of problem:
Currently it is not possible to use LVM on top of iSCSI devices. Basically, 
LVM initialization happens during disk initialization, which is right at the 
start of init. Where as the network and iSCSI (also multipath) services start 
way later. Hence, without iSCSI being started, LVM is not able to initialize 
the PVs because iscsid isn't started and no LUNs are mapped to the host.

There is a work around to this issue by manually re‑scanning the PVs after
the OS has completely booted. But this will be a problem if there are 
applications which are configured to use the LV as their data path because 
the applications will start automatically on system startup and will fail by 
not finding the Logical Volume/Mount Point.

Version-Release number of selected component (if applicable):
All

How reproducible:
Always

Steps to Reproduce:
1. Configure iSCSI and map some LUNs to the host
2. Create a VG/LV on top of those LUNs
3. Set them to auto-mount at boot.
4. Upon boot, the devices aren't mounted because the PV/VG aren't seen to the 
OS
  
Actual results:
Logical Volumes are not found because the LUN was not mapped at the time of 
LVM initialization which further leads to failure of mount points which are 
part of LVM

Expected results:
Device-Mapper should have the ability to do an LVM re-scan when it senses that 
a new block device has been plugged in.


Additional info:
This isn't specific to iSCSI. Can be reproducible with any block device 
providing application which starts-up in init after LVM initialization is 
done.

Comment 2 Mike Christie 2007-05-07 16:42:26 UTC
Did you try to add the _netdev option to fstab? There is some check in the netfs
 script where if it is set, then it kicks off /sbin/lvm.static vgscan.

Comment 3 Andrius Benokraitis 2007-05-17 13:52:46 UTC
Per NetApp, more testing will be done on this, but outlook is good on testing
the GA RHEL 5 version.

Comment 4 Wolfram Richter 2007-05-23 12:10:13 UTC
The _netdev option might help. Except with GFS2 where the _netdev option leads
to a mount error.
Workaround here: Change gfs2 init.d script to include vgchange -ay before mount. 

Comment 5 Tom Coughlan 2007-06-15 18:06:16 UTC
Please let us know whether the solution in commet 2 or 4 resolve this problem. 

Comment 6 Ritesh Raj Sarraf 2007-06-26 06:28:03 UTC
Thanks. The issue is resolved with the option mentioned in Comment #2.
Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.