Bug 232412 - Firefox crashes suddenly
Firefox crashes suddenly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Gecko Maintainer
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 07:18 EDT by John Lau
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 10:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.34 KB, text/plain)
2007-03-16 20:55 EDT, John Lau
no flags Details
Xorg.0.log (67.20 KB, text/plain)
2007-03-16 20:56 EDT, John Lau
no flags Details

  None (edit)
Description John Lau 2007-03-15 07:18:45 EDT
Description of problem:
Firefox crach suddenly on my system. It happens for around 1-2 times a day.
Usually when I open multiple firefox and multiple tabs inside them, and I
scrolling the web page up and down, firefox crash and all the instances
disppeared. It is very annoying.

I try to run firefox-bin once in the console. And when it crash (after several
hours), it shows:

[johnlau@dhcp-0-127 firefox-1.5.0.10]$ ./firefox-bin 
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 8288165 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[johnlau@dhcp-0-127 firefox-1.5.0.10]$ 



Version-Release number of selected component (if applicable):
firefox-1.5.0.10
plugin: Shockwave Flash 9.0 r31

How reproducible:
Open up a firefox, using it for several hours.

Steps to Reproduce:
1. Open several instrance of firefox 
2. Open several tabs inside it
3. Browser some normal web pages (may contain flash) for a few hours

  
Actual results:
firefox crash and every instances disappeared

Expected results:
No crash

Additional info:
Comment 1 Martin Stransky 2007-03-15 07:30:23 EDT
Matej, could you check this one?
Comment 2 John Lau 2007-03-16 01:12:41 EDT
My firefox just crash once again after I use it for a half day. This time I run
firefox-bin with --sync. 
When I use the firefox browsing an email in gmail, (nothing special in the email
), and it crash suddenly when I scrolling up the email.

[johnlau@dhcp-0-127 firefox-1.5.0.10]$ ./firefox-bin --sync
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 22333325 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 3 Matěj Cepl 2007-03-16 07:54:04 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 John Lau 2007-03-16 20:47:07 EDT
Thanks for your response.

I searched about my issue in google yesterday and found most of the people
talking about xorg.conf. And I remember that I just modified my xorg.conf as I
wanted to try the fglrx driver.  So I just rollback my xorg.conf and the problem
haven't happened again so far.

I will upload the xorg.conf and Xorg.*.log of my system yesterday for your
information. I am ok to close this issue. But if you like to continue on this
issue in order to find the root cause, I can use back that problematic xorg.conf
to reproduce the problem.
Comment 5 John Lau 2007-03-16 20:55:00 EDT
Created attachment 150294 [details]
xorg.conf

This is the xorg.conf file I used when I have this issue. Please notice that
although there are some config about fglrx, I use radeon driver actually.
Comment 6 John Lau 2007-03-16 20:56:43 EDT
Created attachment 150295 [details]
Xorg.0.log

The Xorg.0.log when the problem happened.
Comment 7 Martin Stransky 2007-04-12 07:18:48 EDT
looks like a bug in gtk/X. wontfix for now.
Comment 9 Matěj Cepl 2007-04-12 10:13:57 EDT
Sorry, my mistake -- it shouldn't be changed.

Note You need to log in before you can comment on or make changes to this bug.