Bug 232418 - missing/wrong package requirements
missing/wrong package requirements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 09:14 EDT by Karsten Hopp
Modified: 2013-04-30 19:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-16 11:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-03-15 09:14:00 EDT
Description of problem:
The pre/post/... scriptlets requirements look a bit odd and some  are even missing.
caching-nameserver p.e. needs a Requires(post): bind-chroot   for the
bind-chroot-admin script :
  Installing: caching-nameserver           ################### [ 487/1007]
/var/tmp/rpm-tmp.11598: line 4: /usr/sbin/bind-chroot-admin: No such file or
directory
error: %post(caching-nameserver-9.4.0-2.fc7.i386) scriptlet failed, exit status 1


How about these changes:
diff -u -r1.167 bind.spec
--- bind.spec   12 Mar 2007 15:15:37 -0000      1.167
+++ bind.spec   15 Mar 2007 13:09:01 -0000
@@ -145,8 +145,7 @@
 Obsoletes: bind-config
 Provides:  bind-config
 PreReq:    bind = %{epoch}:%{version}-%{release}
-Requires(post):   bash, coreutils, sed, grep
-Requires(postun): bash, coreutils, sed, grep
+Requires(post):   bind-chroot
 %if %{selinux}
 Requires(post): policycoreutils
 Conflicts: selinux-policy-strict < 2.2.0
@@ -169,10 +168,9 @@
 Group:            System Environment/Daemons
 Prefix:    %{chroot_prefix}
 PreReq:    bind = %{epoch}:%{version}-%{release}
-Requires(post):  bash, coreutils, sed, grep
-Requires(preun): bash, coreutils, sed, grep
+Requires(post):  bind-chroot
+Requires(preun): bind-chroot
 %if %{selinux}
-Requires(post): policycoreutils
 Conflicts: selinux-policy-strict < 2.2.0
 Conflicts: selinux-policy-targeted < 2.2.0
 %endif
@@ -191,7 +189,7 @@
 Requires: bind-utils = %{epoch}:%{version}-%{release}
 Requires(pre):    /etc/openldap/schema
 Requires(post):   bash, coreutils, sed, grep, mktemp
-Requires(preun):  bash, coreutils, sed, grep
+Requires(preun):  bash, coreutils, grep
 %if %{selinux}
 Requires(post): policycoreutils
 Conflicts: selinux-policy-strict < 2.2.0
Comment 1 Adam Tkac 2007-03-16 11:28:08 EDT
fixed in bind-*9.4.0-3.fc7

Note You need to log in before you can comment on or make changes to this bug.