Bug 232428 - vncviewer does not use the same font path as a console
vncviewer does not use the same font path as a console
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vnc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
: Desktop
Depends On:
  Show dependency treegraph
Reported: 2007-03-15 10:29 EDT by Suzanne Hillman
Modified: 2013-04-30 19:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-17 07:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2007-03-15 10:29:54 EDT
Description of problem:
vncviewer does not use the same font path as a console. vncviewer appears to set
a font path, rather than using the font server. This can cause interesting
inconsistencies between console-based testing involving fonts and VNC-based
testing. To fix this, set the font path (via "xset fp= unix/:7100" in your VNC
session) to use the font server.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect to a machine via VNC.
2. Attempt to run the test case in bug #189849
Actual results:
Fails because of "Could not create fontset for -*-*-*-R-Normal--14-130-75-75-*-*"

Expected results:
Should just work.

Additional info:
I am unsure if the font server would always be unix/:7100. It might be better to
figure out a way to query what the machine would normally do, and use that.
Comment 1 Adam Tkac 2007-03-27 11:17:45 EDT
Are you really sure that this bug exists in rhel5? vnc works perfectly on rhel5
for me. I run vncserver, with default configuration and I've see nothing related
to this bug (no error like "Could not create fontset.. "). Update rhel version
or give me access for affected machine or upload server's logfile.

Regards, Adam
Comment 2 A S Alam 2007-04-12 08:49:43 EDT
I was also not able to reproduce this bug with mention file on RHEL5 machine
Comment 3 A S Alam 2007-04-12 09:21:03 EDT
tested with bug #189849 Comment #12's Attachment
Comment 4 Adam Tkac 2007-04-12 12:40:53 EDT
(In reply to comment #3)
I was confused because this bug has been opened against rhel5. Let me check
potential problems on rhel4 (also moving this bug to rhel4)


Comment 6 Adam Tkac 2007-04-17 07:13:38 EDT
I tried reproduce bug on up2date rhel4 system and I wasn't successfull. I also
tested with bug #189849 Comment #12's Attachment and all works fine (no "could
not create font path" message). If you're still able to reproduce this one,
please reopen.


Note You need to log in before you can comment on or make changes to this bug.