Bug 23243 - make modules breaks after touching a file
make modules breaks after touching a file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 15:03 EST by Cormac McGaughey
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 15:03:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cormac McGaughey 2001-01-03 15:03:43 EST
This is on a custom install of redhat 7.0, installing everything
the best way to make this bug happen is to do this:
cd /usr/src/linux
make xconfig (set up as needed for your machine)
make depend bzImage
make modules

up to this point everything works perfectly. Now, without changing any 
code do the following (remember I've not updated any code or installed 
anything else at this point - its a pure install):

cd /usr/src/linux/drivers/block
touch DAC960.c
touch DAC960.h
make modules

the compile will break with the following error text:
In file included from ide-cd.c:293:
/usr/src/linux/include/linux/module.h:145: `get_module_symbol_R_ver_str' 
declared as function returning a function
/usr/src/linux/include/linux/module.h:145: warning: parameter names 
(without types) in function declaration
{standard input}: Assembler messages:
{standard input}:9: Warning: Ignoring changed section attributes 
for .modinfo
make[2]: *** [ide-cd.o] Error 1
make[1]: *** [_modsubdir_block] Error 2
make: *** [_mod_drivers] Error 2

Why does it break this way when nothing has been changed, and it compiled 
perfectly seconds before the touch DAC960.c? and why does touching an 
unrelated file break ide-cd?

The only way I can see to fix it is to do a make mrproper every time, 
which is a total pain. Is there a simpler way to make the modules without 
having to recompile everything, every time?

Other modules cause the same error.
Comment 1 Cormac McGaughey 2001-08-07 19:40:08 EDT
The problem does not appear in RedHat 7.1, so it looks like it was specific to 
7.0

Note You need to log in before you can comment on or make changes to this bug.