Bug 232507 - Create Red Hat Global Desktop Channel
Create Red Hat Global Desktop Channel
Status: CLOSED UPSTREAM
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
wes hayutin
:
: 238569 (view as bug list)
Depends On: 82114
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 15:59 EDT by Matt Webbink
Modified: 2008-04-21 12:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss of verification (121.79 KB, image/png)
2007-03-30 13:46 EDT, wes hayutin
no flags Details
RHGD Channel Mappings (200 bytes, text/csv)
2007-04-20 09:50 EDT, Matt Webbink
no flags Details
RHGD Channels (558 bytes, text/csv)
2007-06-13 14:24 EDT, Matt Webbink
no flags Details
RHGD Channels (901 bytes, text/csv)
2007-07-13 16:07 EDT, Matt Webbink
no flags Details

  None (edit)
Description Matt Webbink 2007-03-15 15:59:03 EDT
A single channel needs to be created for the new Red Hat Global Desktop product.

Please see revision # 113302 of rhgd-channels.csv.

The "Version" and "Release" fields will change for the final release - Will
changing this be an issue for the finalized version/release?
Comment 1 Bret McMillan 2007-03-28 15:39:53 EDT
Shouldn't be too hard to change version & release later, but if you don't do it
correctly, you'll might get into a situation where your dev machines are not
registerable, like what happened to RHEL 5 beta 2 machines near RHEL 5 RC 1.
Comment 2 Bret McMillan 2007-03-28 16:26:00 EDT
channel created in webqa.
Comment 3 wes hayutin 2007-03-29 15:37:39 EDT
Hey Bret..
Sorry but I dont see the channel in webqa or the file rhgd-channels.csv in 
http://svn.rhndev.redhat.com/viewcvs/trunk/pm/channels/
or http://svn.rhndev.redhat.com/viewcvs/trunk/pm/mappings/
Comment 4 wes hayutin 2007-03-29 15:58:50 EDT
There appears to be a svn error.. got the file now.. thanks
Comment 5 wes hayutin 2007-03-30 13:46:44 EDT
Created attachment 151298 [details]
ss of verification
Comment 6 Bret McMillan 2007-04-19 19:38:15 EDT
This should be back on QA.  Matt, Norwood, what else do you want done here?
Comment 7 Matt Webbink 2007-04-20 09:50:28 EDT
Created attachment 153184 [details]
RHGD Channel Mappings

Please map the rhgd channel to the SVC0502 and WAR0429 in webqa, per the
attached mapping .csv file (232507.csv).
Comment 8 Bret McMillan 2007-04-20 11:57:09 EDT
Now ON_QA.

Note:  VERIFIED means all aspects of this bug look good on webqa.  If I've only
done half, like create the channel, and you want to use this bug for mappings,
just note that the channel looks good, but move it back to ASSIGNED if there is
more work to be done (in webqa).  Make sense?
Comment 9 Ray Strode [halfline] 2007-04-20 17:43:46 EDT
So I just tried to hock an installation number using the new MCT1088 sku and the
hocked message says,

"Thank you for purchasing MCT1088 - Red Hat Enterprise Linux Global Desktop  
None  1 Year."

The "Enterprise Linux" above in the message is wrong.
Comment 10 wes hayutin 2007-04-23 10:48:59 EDT
k.. not sure if I completely understand this yet.. however here is what I found..

I see the information in the db, like I did in comment #5
however I dont see the global desktop channel listed under all channels in webqa
webgui.

Also the comment in #9 may need to be addressed.

moving back to assigned so Bret can have a look..
thanks.
Comment 11 Bret McMillan 2007-05-08 22:58:17 EDT
Hm, looks like a refresh blew away the mappings.  I've re-run them on webqa, and
I see the stuff here:

https://rhn.webqa.redhat.com/rhn/software/channels/ChannelFamilyTree.do?cfid=5635

Note that I had to tell perl to grant me a particular service:

"perl, grant 10 WAR0429 services to lethallemur in qa"
Comment 12 Bret McMillan 2007-05-08 23:00:00 EDT
*** Bug 238569 has been marked as a duplicate of this bug. ***
Comment 13 Matt Webbink 2007-05-15 13:45:05 EDT
The RHGD SKUs have been setup in webtest.  Please create the channel and apply
the mappings in that environment.

There has also been a request to change the channel version from .91 to 1.  Is
that a problem?
Comment 14 Robin Norwood 2007-05-15 13:52:57 EDT
To clarify, we don't want to change the channel version yet, but we will want to
in the future.
Comment 15 Bret McMillan 2007-05-15 16:32:37 EDT
Moved to webtest, setting to the env-odd ON_QA
Comment 16 Robin Norwood 2007-05-22 13:58:44 EDT
The 'version' and 'release' fields should now both be '1' for the next time
channels are pushed.
Comment 17 Robin Norwood 2007-05-23 16:53:40 EDT
I just got work from brian litton that the SKU's have been propogated to QA - so
it should not be time to create the channel (with version=1).
Comment 18 Bret McMillan 2007-05-24 15:33:28 EDT
channel & mappings pushed to webqa.
Comment 19 Robin Norwood 2007-05-29 18:33:12 EDT
From Bryan Litton <blitton@redhat.com>:


> If this is the case then it is just a matter of getting the RHN
> mappings complete. WAR0429 needs to be linked to MCT1088 in the RHN
> table if I understand the process correctly. I am not sure who does
> this on the RHN side, but I think this is the last step.


Can someone take care of this for me, please?
Comment 20 Bret McMillan 2007-05-31 13:39:55 EDT
Mappings pushed into webqa.
Comment 21 Robin Norwood 2007-05-31 15:32:06 EDT
Alas, I'm still not getting any channel entitlements.

I hocked new installation numbers using the MCT1088 item code, registered with
one of those installation numbers, but my account still gets no channel
entitlements.

The user is 'RHGD-ae91-60cf-df4f-4363' and the installation key is:
'ae91-60cf-df4f-4363'.  Any idea what is broken?
Comment 24 Bret McMillan 2007-05-31 21:00:39 EDT
So, after some unit tests, looks like the service reports successful
entitlements, but nothing is showing up in the EP.  We'll have to follow this up
w/ the service & other IT folks to ensure things are populating the EP correctly
in webqa.
Comment 25 Bret McMillan 2007-06-01 14:47:20 EDT
jsprague is helping us w/ clehew is on pto...
Comment 26 Jared Sprague 2007-06-01 15:38:42 EDT
I think I've narrowed down the problem in the entitlement service, but we'll
need Clehew's knowledge of the inner workings of that service, when he comes in
on monday. before we can apply a fix.
Comment 27 Matt Webbink 2007-06-13 14:24:36 EDT
Created attachment 156898 [details]
RHGD Channels

Release field updated to "1" in rhgd-channels.csv.
Comment 28 James Bowes 2007-06-14 08:40:54 EDT
(In reply to comment #27)
> Created an attachment (id=156898) [edit]
> RHGD Channels
> 
> Release field updated to "1" in rhgd-channels.csv.

Updated in webqa
Comment 29 Robin Norwood 2007-06-20 12:50:01 EDT
Bryan Litton has just created the SKUs in stage.  Could you please create the
channels?
Comment 30 Bret McMillan 2007-06-20 16:17:37 EDT
Ticket filed w/ prod-ops to create the channel there; once that's complete I'll
run the mappings (hopefully tonight).
Comment 31 James Bowes 2007-06-21 16:38:21 EDT
WAR0429 does not seem to exist in stage.
Comment 32 Bret McMillan 2007-06-28 14:08:15 EDT
John Chapman working with Ramesh to make sure oaisync is working correctly in stage.
Comment 33 Bret McMillan 2007-06-29 17:28:39 EDT
Mappings have been applied to stage.
Comment 34 Matt Webbink 2007-07-13 16:07:23 EDT
Created attachment 159237 [details]
RHGD Channels

Please add new child channel (rhgd-i386-media-1) to existing RHGD channel
family.
Comment 35 Robin Norwood 2007-07-19 15:18:35 EDT
This was ON_QA, but probably needs to be ASSIGNED.

Bretm - is the channel in yet?
Comment 36 Bret McMillan 2007-07-20 12:13:23 EDT
channel is now webqa, there were problems with the csv:

1)  string names were too long, i chopped 'em down a bit.  see if they're
satisfactory

2)  you double-dipped into the rhgd-client channel family, the media stuff
needed it's own.  I created one called 'rhgd-media', and updated both sku
mappings to provide one slot of it.
Comment 37 Tom "spot" Callaway 2007-08-14 11:37:18 EDT
Can we get the rhgd-i386-client-1 channel created on stage, if it doesn't
already exist there?

Thanks,

~spot
Comment 38 James Bowes 2008-04-21 12:17:22 EDT
closing. if more requests are needed, they can be put in a new bug

Note You need to log in before you can comment on or make changes to this bug.