Bug 232537 - package is missing files required to run properly
package is missing files required to run properly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-15 20:41 EDT by R. Morton jr
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 13:31:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R. Morton jr 2007-03-15 20:41:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070312 Firefox/2.0.0.2

Description of problem:
try to find what modules to load for gnome-sesnor-applet applet show no chip find but 
  /usr/bin/sensors
k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:
             +26°C
Core1 Temp:
             +30°C

show this

Version-Release number of selected component (if applicable):
lm_sensors-2.10.2-1.fc7

How reproducible:
Always


Steps to Reproduce:
1.sudo sensors-detect
2.password
3. answer yes to first 2 quesions

Actual Results:
stop with error message

Expected Results:
find modules and  add to /etc/modprobe.conf


Additional info:
[majeh@localhost ~]$ sudo /usr/sbin/sensors-detect
Password:
# sensors-detect revision 4271 (2006-12-26 03:53:20 -0800)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

We can start with probing for (PCI) I2C or SMBus adapters.
Do you want to probe now? (YES/no): y
Probing for PCI bus adapters...
Use driver `i2c-nforce2' for device 0000:00:09.1: nVidia Corporation nForce4 SMBus (MCP55)

We will now try to load each adapter module in turn.
Module `i2c-nforce2' already loaded.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

To continue, we need module `i2c-dev' to be loaded.
Do you want to load `i2c-dev' now? (YES/no): y
Module loaded successfully.

We are now going to do the I2C/SMBus adapter probings. Some chips may
be double detected; we choose the one with the highest confidence
value in that case.
If you found that the adapter hung after probing a certain address,
you can specify that address to remain unprobed.
Can't exec "i2cdetect": No such file or directory at /usr/sbin/sensors-detect line 5595, <STDIN> line 2.
Couldn't find i2cdetect program!! at /usr/sbin/sensors-detect line 5595, <STDIN> line 2.
[majeh@localhost ~]$
Comment 1 Hans de Goede 2007-07-06 15:32:02 EDT
Hi,

Short introduction, I'm a Fedora contributer and since I'm involved in
lm_sensors upstream, I've also become a co-maintainer of lm_sensors in Fedora.

Strange bug this, i2cdetect is included in our package and sensors-detect
searches at the proper location.

Can you try updating to the latest lm_sensors package and then try this again.

Also please include the output of: "rpm --verify lm_sensors"
Comment 2 Hans de Goede 2007-07-10 14:52:45 EDT
R. Morton jr,

I've good reasons to believe this bug (sensors-detect not being able to find
i2cdetect) has been fixed a long time ago. Please upgrade to the latest version
of lm_sensors and try again. If you do not respond within a week I will close
this bug (you can always reopen it if you find later that the bug persists).

As for your other problem: gnome-applet-sensors not showing the k8temp chip
temperatures that is a gnome-applet-sensors problem, if you still have that
problem, please file a bug against gnome-applet-sensors for this.

Thanks!
Comment 3 Hans de Goede 2007-07-17 13:31:30 EDT
No response to inquiries from reporter and I've verified that the described
problem is no longer present, closing.

Note You need to log in before you can comment on or make changes to this bug.