Bug 232608 - Virtual disk size wraps around at 2 TB mark
Virtual disk size wraps around at 2 TB mark
Status: CLOSED DUPLICATE of bug 217580
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Depends On: 216555
  Show dependency treegraph
Reported: 2007-03-16 08:50 EDT by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-16 09:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2007-03-16 08:50:12 EDT
+++ This bug was initially created as a clone of Bug #216555 +++

Description of problem:
If I create a virtual disk (either a file, or block device backed) in the dom0
host with a size of 5 TB, and export this to a guest DomU, the domu will only
see it as being 1 TB in size. It looks as if the Xen virtual disk driver is
wrapping around at the 2 TB mark.

Version-Release number of selected component (if applicable):

How reproducible:
Always (on 32-bit)

Steps to Reproduce:
1. Create an block device 7 TB in size
2. Export this to the DomU in the guest config file
3. Look at /proc/partitions inside the guest kernel
4. Look at /proc/partitions in the dom0 host kernel
Actual results:
The #blocks column for the disk is different in DomU & Dom0

Expected results:
The #blocks seen in DomU matches #blocks seen in Dom0

Additional info:
The same problem occurs for file backed virtual disks on 32-bit host/guest.

There is no problem on 64-bit kernels - I have exported disks as large as 15 PB
 to the guest.

This is all testing with paravirt guests. Not verified if fully virt guests have
any issues yet.

Post from Ian upstream suggests 32-bit wraparound in blkfront driver


-- Additional comment from berrange@redhat.com on 2006-11-21 07:39 EST --
Patch committed in xen-unstable.hg


-- Additional comment from berrange@redhat.com on 2006-11-21 17:44 EST --
I have tested the patch listed in comment #2 and confirmed it fixes operation of
file: and phy: backed disks > 2 TB in size. It does not, however, fix tap:aio:
backed disks.

-- Additional comment from berrange@redhat.com on 2006-11-21 17:45 EST --
Created an attachment (id=141844)
Patch for blktap based disks

This additional patch fixes blktap based disks which are > 2TB
Comment 2 Stephen Tweedie 2007-03-16 09:10:50 EDT

*** This bug has been marked as a duplicate of 217580 ***
Comment 4 Robin Bowes 2007-03-17 12:15:54 EDT
Has this fix made it into any released software (FC or RHEL) ?
Comment 5 Stephen Tweedie 2007-03-19 18:57:10 EDT
Yes, the fix should be in both RHEL-5 and rawhide.

Note You need to log in before you can comment on or make changes to this bug.