Bug 23268 - locate: decode_db() aborted. Corrupt database?
locate: decode_db() aborted. Corrupt database?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: slocate (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 22:58 EST by Wenzhuo Zhang
Modified: 2014-03-16 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-04 12:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenzhuo Zhang 2001-01-03 22:58:12 EST
updated slocate to the slocate-2.4-0.6.x a week ago, but noticed this
problem today.

After each 'locate something', locate prints out the error message:
 	"locate: decode_db() aborted. Corrupt database?"

I tried to remove /var/lib/slocate/slocate.db and rebuild the database, 
but to no avail. I don't know if the problem is reproduceable. Here is the
related information of my system:

[root@drum slocate]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda1               497829     92423    379704  20% /
/dev/hda3              1209604     89684   1058472   8% /var
/dev/hda4             17773200   8151580   8718768  48% /home
/dev/hdb1               608724    444408    133396  77% /opt
/dev/hdb3              2071416    805868   1160324  41% /usr
/dev/hdb4             11622416   7157828   3874200  65% /home/ftp


[root@drum slocate]# find  /  |  wc
 287340  486027 17817357 


[root@drum slocate]# fdisk -l
 
Disk /dev/hda: 255 heads, 63 sectors, 2482 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1        64    514048+  83  Linux
/dev/hda2            65        81    136552+  82  Linux swap
/dev/hda3            82       234   1228972+  83  Linux
/dev/hda4           235      2482  18057060   83  Linux
 
Disk /dev/hdb: 255 heads, 63 sectors, 1826 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1        77    618471   83  Linux
/dev/hdb2            78        94    136552+  82  Linux swap
/dev/hdb3            95       356   2104515   83  Linux
/dev/hdb4           357      1826  11807775   83  Linux
Comment 1 Bill Nottingham 2001-01-04 12:25:36 EST
Can you post the db that it created?
Comment 2 Bill Nottingham 2001-01-06 17:38:57 EST
This should be fixed in slocate-2.5-1, which will be in the next raw hide release.
Comment 3 Scarlett 2001-01-11 23:38:05 EST
I am also experiencing the same problem.  Reverting back to slocate-2.1-2 fixed
the problem.

Note You need to log in before you can comment on or make changes to this bug.