Bug 232741 - failure to activate pre-existing logical volumes
Summary: failure to activate pre-existing logical volumes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 00:13 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 07:52:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2007-03-17 00:13:33 UTC
Kickstart install on x86_64, /boot and one swap partition in regular partitions,
/, more swap and other stuff in logical volumes.

When the time comes to activate swap devices, IIRC before resolving deps, we get
a failure (must reboot) because the logical volumes are not active.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.37-1

Comment 1 Alexandre Oliva 2007-03-17 03:11:38 UTC
It's not just about swap.  If I disable the swap device entirely (removing even
the magic numbers, otherwise #!#!& :-) anaconda will still recognize it and try
to use it automatically) it then fails to format the root partition.

I tried to start a sleep 1 && lvm vgchange -ay loop in VT2, to no avail.  It's
probably deactivating everything and then trying to use the devices as if they
were active too fast for such a loop to win the race :-(

Comment 2 Chris Lumens 2007-03-23 18:16:40 UTC
Can you attach your kickstart file and the contents of the error message to this
bug report?

Comment 3 Alexandre Oliva 2007-05-07 05:45:53 UTC
Created attachment 154240 [details]
Example of kickstart file (among many) that triggers the problem

Sorry that it took so long.  The error message is:

Error enabling swap device all/swap: No such file or directory

This most likely means this swap partition has not been initialized.

Press OK to reboot your system.


This message is displayed after it formats and brings up /dev/sda2 as one of
the swap devices.

in VT3, I see a list of the LVs, the message about formatting sda2, and then
the list of LVs again.

lvm vgdisplay shows none of the LVs are active.  We're missing an lvm vgchange
-ay before this point.

Comment 4 Chris Lumens 2007-05-07 13:47:35 UTC
This should be fixed in the latest build of anaconda.  Peter committed some code
on Friday to take care of this problem.

Comment 5 Alexandre Oliva 2007-05-16 07:52:32 UTC
Confirmed fixed in the 20070511 merged tree, thanks.


Note You need to log in before you can comment on or make changes to this bug.