Bug 232769 - texdoc searches $TEXMF/doc -- should use $TEXMFDOCS
Summary: texdoc searches $TEXMF/doc -- should use $TEXMFDOCS
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 232771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-17 12:46 UTC by George N. White III
Modified: 2013-07-02 23:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 11:36:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George N. White III 2007-03-17 12:46:53 UTC
Description of problem: documentation is not found if system uses a non-default
TEXDOCS path


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. add non-standard directory to TEXDOCS in texmf.cnf
2. texdoc fails to find the new documentation
3.
  
Actual results:


Expected results:


Additional info:

Here is the patch posted to the tex-live list by Frank Küster:

Subject: [tex-live] texdoc should always use TEXDOCS

Hi,

a Debian user has noticed that, although texdoc uses 'kpsewhich
--format="TeX system documentation"' and thus the $TEXDOCS variable for
its main work, the search mode accesses $TEXMF/doc directly and ignores
changes/additions in TEXDOC.

The following patch would make it more consistent:

--- src/Upstream-source/TeXLive/Build/source/texk/tetex/texdoc.orig	2007-03-
15 16:36:30.000000000 +0100
+++ src/Upstream-source/TeXLive/Build/source/texk/tetex/texdoc	2007-03-15 
16:37:20.000000000 +0100
@@ -140,7 +140,7 @@
 do
   case $mode in
     search)
-      find `kpsewhich --expand-path='$TEXMF/doc' | tr : ' '` -type f -print |
+      find `kpsewhich --expand-path='$TEXDOCS' | tr : ' '` -type f -print |
         egrep $name
       continue
       ;;

(too simple to be copyrightable, of course).

Comment 1 George N. White III 2007-03-17 14:42:27 UTC
*** Bug 232771 has been marked as a duplicate of this bug. ***

Comment 2 Jindrich Novy 2007-04-02 11:36:28 UTC
Fixed, thanks!

Comment 3 Fedora Update System 2007-04-13 19:37:03 UTC
tetex-3.0-34.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.