Bug 232814 - Kernel 2990 bcm43xx messages
Kernel 2990 bcm43xx messages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-18 07:29 EDT by Patrick
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 14:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick 2007-03-18 07:29:05 EDT
Description of problem:
Per Dave Jones request here is a copy of the bcm43xx kernel messages that showed
up when booting with the 2990 kernel while these did not show up running the
2985 kernel. This is on a laptop with the Broadcom bcm4318 chip.

Version-Release number of selected component (if applicable):
2.6.20-1.2990.fc7

How reproducible:
Did not try

Steps to Reproduce:
1. 
2. 
3. 
  
Actual results:
A lot of bcm43xx messages showed up

Expected results:
Messages should not be there

Additional info:
Mar 17 15:51:07 localhost kernel: bcm43xx: PHY connected
Mar 17 15:51:08 localhost kernel: bcm43xx: Microcode rev 0x127, pl 0xe
(2005-04-18  02:36:27)
Mar 17 15:51:08 localhost kernel: bcm43xx: Radio turned on
Mar 17 15:51:08 localhost kernel: bcm43xx: Radio enabled by hardware
Mar 17 15:51:08 localhost kernel: bcm43xx: ASSERTION FAILED (radio_attenuation <
10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1501:bcm43xx_find_lopair()
Mar 17 15:51:08 localhost kernel: bcm43xx: WARNING: Writing invalid LOpair (low:
-116, high: -34, index: 120)
Mar 17 15:51:08 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 17 15:51:08 localhost kernel:  [<c04067b1>] show_trace+0x12/0x14
Mar 17 15:51:08 localhost kernel:  [<c0406835>] dump_stack+0x16/0x18
Mar 17 15:51:08 localhost kernel:  [<f94c3c5f>]
bcm43xx_phy_lo_adjust+0x1f1/0x22f [bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94c0c9b>]
bcm43xx_radio_set_txpower_bg+0x210/0x225 [bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94c5865>] bcm43xx_phy_initb6+0x6da/0x80d
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94c5a43>] bcm43xx_phy_initg+0xab/0xcf7
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94c76b9>] bcm43xx_phy_init+0x60e/0x62c
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94b813f>] bcm43xx_chip_init+0x7d4/0xad0
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94b9803>] wireless_core_up+0x187/0x682
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94ba07b>]
bcm43xx_select_wireless_core+0x37d/0x4fe [bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94ba2f8>] bcm43xx_init_board+0x4a/0x124
[bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<f94baa84>] bcm43xx_net_open+0xd/0xf [bcm43xx]
Mar 17 15:51:08 localhost kernel:  [<c05b4309>] dev_open+0x2e/0x66
Mar 17 15:51:08 localhost kernel:  [<c05b2c6d>] dev_change_flags+0x51/0xf1
Mar 17 15:51:08 localhost kernel:  [<c05bb01b>] rtnl_setlink+0x265/0x37e
Mar 17 15:51:08 localhost kernel:  [<c05ba624>] rtnetlink_rcv_msg+0x1b9/0x1dc
Mar 17 15:51:08 localhost kernel:  [<c05c6bf1>] netlink_run_queue+0x65/0xd1
Mar 17 15:51:08 localhost kernel:  [<c05ba421>] rtnetlink_rcv+0x29/0x42
Mar 17 15:51:08 localhost kernel:  [<c05c707c>] netlink_data_ready+0x15/0x56
Mar 17 15:51:08 localhost kernel:  [<c05c6061>] netlink_sendskb+0x1f/0x37
Mar 17 15:51:08 localhost kernel:  [<c05c694c>] netlink_unicast+0x1ab/0x1c5
Mar 17 15:51:08 localhost kernel:  [<c05c705b>] netlink_sendmsg+0x271/0x27d
Mar 17 15:51:08 localhost kernel:  [<c05aa077>] sock_sendmsg+0xe7/0x104
Mar 17 15:51:08 localhost kernel:  [<c05aa1e5>] sys_sendmsg+0x151/0x1af
Mar 17 15:51:08 localhost kernel:  [<c05ab1d0>] sys_socketcall+0x220/0x241
Mar 17 15:51:08 localhost kernel:  [<c040507c>] syscall_call+0x7/0xb
Mar 17 15:51:08 localhost kernel:  =======================
Mar 17 15:51:09 localhost kernel: bcm43xx: ASSERTION FAILED (radio_attenuation <
10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1501:bcm43xx_find_lopair()
Mar 17 15:51:09 localhost kernel: bcm43xx: WARNING: Writing invalid LOpair (low:
-116, high: -34, index: 120)
Mar 17 15:51:09 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 17 15:51:09 localhost kernel:  [<c04067b1>] show_trace+0x12/0x14
Mar 17 15:51:09 localhost kernel:  [<c0406835>] dump_stack+0x16/0x18
Mar 17 15:51:09 localhost kernel:  [<f94c3c5f>]
bcm43xx_phy_lo_adjust+0x1f1/0x22f [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c6542>] bcm43xx_phy_initg+0xbaa/0xcf7
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c76b9>] bcm43xx_phy_init+0x60e/0x62c
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94b813f>] bcm43xx_chip_init+0x7d4/0xad0
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94b9803>] wireless_core_up+0x187/0x682
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94ba07b>]
bcm43xx_select_wireless_core+0x37d/0x4fe [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94ba2f8>] bcm43xx_init_board+0x4a/0x124
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94baa84>] bcm43xx_net_open+0xd/0xf [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<c05b4309>] dev_open+0x2e/0x66
Mar 17 15:51:09 localhost kernel:  [<c05b2c6d>] dev_change_flags+0x51/0xf1
Mar 17 15:51:09 localhost kernel:  [<c05bb01b>] rtnl_setlink+0x265/0x37e
Mar 17 15:51:09 localhost kernel:  [<c05ba624>] rtnetlink_rcv_msg+0x1b9/0x1dc
Mar 17 15:51:09 localhost kernel:  [<c05c6bf1>] netlink_run_queue+0x65/0xd1
Mar 17 15:51:09 localhost kernel:  [<c05ba421>] rtnetlink_rcv+0x29/0x42
Mar 17 15:51:09 localhost kernel:  [<c05c707c>] netlink_data_ready+0x15/0x56
Mar 17 15:51:09 localhost kernel:  [<c05c6061>] netlink_sendskb+0x1f/0x37
Mar 17 15:51:09 localhost kernel:  [<c05c694c>] netlink_unicast+0x1ab/0x1c5
Mar 17 15:51:09 localhost kernel:  [<c05c705b>] netlink_sendmsg+0x271/0x27d
Mar 17 15:51:09 localhost kernel:  [<c05aa077>] sock_sendmsg+0xe7/0x104
Mar 17 15:51:09 localhost kernel:  [<c05aa1e5>] sys_sendmsg+0x151/0x1af
Mar 17 15:51:09 localhost kernel:  [<c05ab1d0>] sys_socketcall+0x220/0x241
Mar 17 15:51:09 localhost kernel:  [<c040507c>] syscall_call+0x7/0xb
Mar 17 15:51:09 localhost kernel:  =======================
Mar 17 15:51:09 localhost kernel: bcm43xx: ASSERTION FAILED (radio_attenuation <
10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1501:bcm43xx_find_lopair()
Mar 17 15:51:09 localhost kernel: bcm43xx: WARNING: Writing invalid LOpair (low:
-116, high: -34, index: 120)
Mar 17 15:51:09 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 17 15:51:09 localhost kernel:  [<c04067b1>] show_trace+0x12/0x14
Mar 17 15:51:09 localhost kernel:  [<c0406835>] dump_stack+0x16/0x18
Mar 17 15:51:09 localhost kernel:  [<f94c3c5f>]
bcm43xx_phy_lo_adjust+0x1f1/0x22f [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c0c9b>]
bcm43xx_radio_set_txpower_bg+0x210/0x225 [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c3a51>]
bcm43xx_phy_init_pctl+0x20f/0x22c [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c661e>] bcm43xx_phy_initg+0xc86/0xcf7
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c76b9>] bcm43xx_phy_init+0x60e/0x62c
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94b813f>] bcm43xx_chip_init+0x7d4/0xad0
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94b9803>] wireless_core_up+0x187/0x682
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94ba07b>]
bcm43xx_select_wireless_core+0x37d/0x4fe [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94ba2f8>] bcm43xx_init_board+0x4a/0x124
[bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94baa84>] bcm43xx_net_open+0xd/0xf [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<c05b4309>] dev_open+0x2e/0x66
Mar 17 15:51:09 localhost kernel:  [<c05b2c6d>] dev_change_flags+0x51/0xf1
Mar 17 15:51:09 localhost kernel:  [<c05bb01b>] rtnl_setlink+0x265/0x37e
Mar 17 15:51:09 localhost kernel:  [<c05ba624>] rtnetlink_rcv_msg+0x1b9/0x1dc
Mar 17 15:51:09 localhost kernel:  [<c05c6bf1>] netlink_run_queue+0x65/0xd1
Mar 17 15:51:09 localhost kernel:  [<c05ba421>] rtnetlink_rcv+0x29/0x42
Mar 17 15:51:09 localhost kernel:  [<c05c707c>] netlink_data_ready+0x15/0x56
Mar 17 15:51:09 localhost kernel:  [<c05c6061>] netlink_sendskb+0x1f/0x37
Mar 17 15:51:09 localhost kernel:  [<c05c694c>] netlink_unicast+0x1ab/0x1c5
Mar 17 15:51:09 localhost kernel:  [<c05c705b>] netlink_sendmsg+0x271/0x27d
Mar 17 15:51:09 localhost kernel:  [<c05aa077>] sock_sendmsg+0xe7/0x104
Mar 17 15:51:09 localhost kernel:  [<c05aa1e5>] sys_sendmsg+0x151/0x1af
Mar 17 15:51:09 localhost kernel:  [<c05ab1d0>] sys_socketcall+0x220/0x241
Mar 17 15:51:09 localhost kernel:  [<c040507c>] syscall_call+0x7/0xb
Mar 17 15:51:09 localhost kernel:  =======================
Mar 17 15:51:09 localhost kernel: bcm43xx: Chip initialized
Mar 17 15:51:09 localhost kernel: bcm43xx: 32-bit DMA initialized
Mar 17 15:51:09 localhost kernel: bcm43xx: Keys cleared
Mar 17 15:51:09 localhost kernel: bcm43xx: Selected 802.11 core (phytype 2)
Mar 17 15:51:09 localhost kernel: bcm43xx: ASSERTION FAILED (radio_attenuation <
10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1501:bcm43xx_find_lopair()
Mar 17 15:51:09 localhost kernel: bcm43xx: WARNING: Writing invalid LOpair (low:
-116, high: -34, index: 120)
Mar 17 15:51:09 localhost kernel:  [<c04061ed>] show_trace_log_lvl+0x1a/0x2f
Mar 17 15:51:09 localhost kernel:  [<c04067b1>] show_trace+0x12/0x14
Mar 17 15:51:09 localhost kernel:  [<c0406835>] dump_stack+0x16/0x18
Mar 17 15:51:09 localhost kernel:  [<f94c3c5f>]
bcm43xx_phy_lo_adjust+0x1f1/0x22f [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94c4a5e>]
bcm43xx_phy_lo_g_measure+0x8ca/0xaa6 [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<f94baf6b>]
bcm43xx_periodic_work_handler+0x176/0x42b [bcm43xx]
Mar 17 15:51:09 localhost kernel:  [<c04350af>] run_workqueue+0x89/0x145
Mar 17 15:51:09 localhost kernel:  [<c0435abc>] worker_thread+0xf8/0x124
Mar 17 15:51:09 localhost kernel:  [<c043829f>] kthread+0xb3/0xdc
Mar 17 15:51:09 localhost kernel:  [<c0405cd7>] kernel_thread_helper+0x7/0x10
Mar 17 15:51:09 localhost kernel:  =======================
Mar 17 15:51:09 localhost NetworkManager: <info>  eth1: Device is
fully-supported using driver 'bcm43xx'. 
Mar 17 15:51:09 localhost NetworkManager: <info>  nm_device_init(): waiting for
device's worker thread to start 
Mar 17 15:51:09 localhost NetworkManager: <info>  nm_device_init(): device's
worker thread started, continuing. 
Mar 17 15:51:09 localhost NetworkManager: <info>  Now managing wireless (802.11)
device 'eth1'.
Comment 1 John W. Linville 2007-03-21 14:45:07 EDT
The 4318 is still not well supported, and the maintainer tells me that these 
messages are not unexpected on a 4318.

Out of curiousity, have you tried the bcm43xx_mac80211 driver as an 
alternative?  Of course, I doubt if it works any better for the 4318...
Comment 2 Patrick 2007-04-02 19:23:18 EDT
No haven' tried it but I will try and report back once I can get my hands on it
since I gave it to my gf. Should be hopefully this weekend.
Comment 3 Patrick 2007-04-07 13:31:42 EDT
The bcm43xx_mac80211 module doesn't work either.
Comment 4 John W. Linville 2007-05-18 14:22:22 EDT
I'm going to close this as RAWHIDE, as I don't think you'll see these messages 
anymore.  Please note that the 4318 is still hit-or-miss -- it has a good 
chance of working if you sit close to the AP... :-(  But, at least your logs 
should not be full of the junk in the report above.

Note You need to log in before you can comment on or make changes to this bug.