Bug 232914 - /etc/init.d/syslog doesn't properly implement reload
/etc/init.d/syslog doesn't properly implement reload
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysklogd (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks: 241434
  Show dependency treegraph
 
Reported: 2007-03-19 10:17 EDT by Boris Folgmann
Modified: 2008-04-09 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0162
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2007-03-19 10:17:14 EDT
+++ This bug was initially created as a clone of Bug #62679 +++

From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.9-31 i686)

Description of problem:
/etc/init.d/syslog help
pretends that it does not support reload. In fact reload is implemented as a
restart in /etc/init.d/syslog.

That is bad. Please implement reload as sending SIG_HUP to the syslogd. See man
syslogd for details.


Version-Release number of selected component (if applicable):
sysklogd-1.4.1-26_EL

How reproducible:
Always

Steps to Reproduce:
/etc/init.d/syslog reload


	

Actual Results:  The same as doing /etc/init.d/syslog restart


Additional info:

-- Additional comment from jvdias@redhat.com on 2005-06-07 18:28 EST --
Very sorry for the long delay in responding to this bug.
Somehow this bug slipped through the cracks - I just discovered it
(I've recently taken over maintenance of the syslogd package).

I agree - the next version of syslogd (1.4.1-31+) will have an
initscript that supports the "reload" command by sending a SIGHUP
to syslogd.



-- Additional comment from notting@redhat.com on 2006-08-04 16:36 EST --
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.
Comment 1 Peter Vrabec 2007-03-19 19:04:14 EDT
This issue is fixed since FC-5 and RHEL-5.
Comment 2 Kevin Graham 2007-08-09 09:05:29 EDT
Do we need a separate bug to get this init script fix integrated as RHEL4 errata?
Comment 3 Peter Vrabec 2007-08-09 11:10:39 EDT
No, we only need to get ACKs here.
Comment 10 errata-xmlrpc 2008-04-09 12:15:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0162.html

Note You need to log in before you can comment on or make changes to this bug.