Bug 232972 - hal quietly stops after "service messagebus restart"
Summary: hal quietly stops after "service messagebus restart"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-19 18:29 UTC by Michal Jaegermann
Modified: 2013-03-06 03:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 23:30:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-03-19 18:29:27 UTC
Description of problem:

I bumped into that sort of by an accident.  Immediately after

    service messagebus restart

a check 'service haldaemon status' shows "is running..." but
if this is repeated after a short delay, say ten seconds, then
it comes as "is stopped".  No log traces or anything else.  Just
hald goes away.

One can say "don't do it, then" but a restart of a messagebus
service may happen for some reasons.  Is an effect on hald intended?
It could be possible in /etc/init.d/messagebus to check in 'restart'
if hald is running and restart it too if this was the case.  It looks
that this would prevent such surprises.

Version-Release number of selected component (if applicable):
hal-0.5.9-0.git20070304.fc7
dbus-1.0.1-3.fc7

How reproducible:
always

Comment 1 David Zeuthen 2007-03-19 19:42:12 UTC
There's a good reason the messagebus isn't restarted on package upgrades.
Nevertheless hald does try to connect to the bus when it disappaers and jumps on
it if it becomes available. If this doesn't work it's a bug.

Comment 2 David Zeuthen 2007-04-02 23:30:16 UTC
This was fixed by this commit

 http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=a48af028e1e48dcd89740153a3da2bfebbec0867

and that code is in RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.