Bug 232991 - sata_sil causes system freeze
sata_sil causes system freeze
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
:
: 232992 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-19 15:46 EDT by Robert M Williams
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 21:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci information (1.99 KB, text/plain)
2007-03-19 15:56 EDT, Robert M Williams
no flags Details
dmesg output (31.02 KB, text/plain)
2007-03-19 15:57 EDT, Robert M Williams
no flags Details
messages log (122.38 KB, text/plain)
2007-03-19 16:01 EDT, Robert M Williams
no flags Details
install log (39.21 KB, text/plain)
2007-03-19 16:03 EDT, Robert M Williams
no flags Details
install syslog (3.78 KB, text/plain)
2007-03-19 16:04 EDT, Robert M Williams
no flags Details

  None (edit)
Description Robert M Williams 2007-03-19 15:46:30 EDT
Description of problem:
during the loading of the sata_sil driver the system will freeze until a mouse/
keyboard event occurs.
it will freeze again moments later until another mouse/keyboard event takes 
place.
if no mouse/keyboard event occurs 'Clocksource tsc unstable (delta=14059955850 
ns)' occurs

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.boot system
2.at 'PM: Adding info for No Bus :host1' message system will freeze
3.to proceed continous mouse movement is reqired for entire session (including 
logoff) or freeze will occur
  
Actual results:
system freeze

Expected results:
'normal' operation without continous input

Additional info:
system: 
- AMD Turion X2 based CPU 1.6 GHz
- 1 GB DDR2 ram
- 80GB hd (sata based)
- dvd+-rw (ata based)

This does not occur if using the x86_64 version of Fedora 7 b2 on the same 
system

have tried changing the clock source via kernel params (pit and pmtmr) with no 
effect

have tried adding libata.atapi_enabled=1 to no effect

have applied latest update as of time of bug filing

does not occur on 'PM: Adding info for No Bus :host0' load
Comment 1 Robert M Williams 2007-03-19 15:52:20 EDT
*** Bug 232992 has been marked as a duplicate of this bug. ***
Comment 2 Robert M Williams 2007-03-19 15:56:27 EDT
Created attachment 150425 [details]
lspci information
Comment 3 Robert M Williams 2007-03-19 15:57:44 EDT
Created attachment 150426 [details]
dmesg output
Comment 4 Robert M Williams 2007-03-19 16:01:38 EDT
Created attachment 150428 [details]
messages log
Comment 5 Robert M Williams 2007-03-19 16:03:42 EDT
Created attachment 150429 [details]
install log
Comment 6 Robert M Williams 2007-03-19 16:04:18 EDT
Created attachment 150430 [details]
install syslog
Comment 7 Chuck Ebbert 2007-03-26 10:48:14 EDT
Test kernels (version 1.2937) for this issue are at:

http://people.redhat.com/cebbert

Please test and report back.
Comment 8 Robert M Williams 2007-03-26 14:35:26 EDT
tried build 20070325 (kernel 2.6.20-1.3017) and now the problem occurs before
sata_sil loads
it now begins with /sbin/loader notification
as before constant mouse or keyboard events allow the system to proceed
Comment 9 Chuck Ebbert 2007-03-26 14:48:51 EDT
Sorry, I thought this was an FC6 bug.
Comment 10 Robert M Williams 2007-03-26 15:09:27 EDT
plugged in an external usb mouse and install proceeds with fewer movements required.
however after the hard disk formats and 'transfering install image' is displayed
the screen goes white and system hard locks.
Comment 11 Dave Jones 2007-04-23 12:47:43 EDT
options to try booting with..

pci=routeirq
noapic
nolapic
noapic nolapic
nolapic_timer
Comment 12 Bug Zapper 2008-04-03 19:43:38 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 13 Bug Zapper 2008-05-06 21:18:48 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.