Bug 233018 - gnome-terminal crash on startup when on beryl or compiz, x86_64, nvidia graphics
gnome-terminal crash on startup when on beryl or compiz, x86_64, nvidia graphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-19 17:53 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-25 00:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 231145 None None None Never
Red Hat Bugzilla 231170 None None None Never
Red Hat Bugzilla 231184 None None None Never
Red Hat Bugzilla 233018 None None None Never

  None (edit)
Description John Ellson 2007-03-19 17:53:03 EDT
Description of problem:
gnome-terminal crashes immediately on startup, bringing down all other
established gnome-terminals, when starting on beryl or compiz.   OK on metacity.

This is an x86_64 platform with nvidia graphics

Version-Release number of selected component (if applicable):
gnome-terminal-2.18.0-1.fc7.x86_64
glib2-2.12.11-1.fc7.x86_64
gtk2-2.10.11-1.fc7.x86_64
beryl-0.2.0-1.fc7.x86_64

NVIDIA-Linux-x86_64-1.0-9755

How reproducible:
100%

Steps to Reproduce:
1.start beryl window manager
2.start new gnome-terminal
3.
  
Actual results:

ellson@ontap:~> gnome-terminal
The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1139 error_code 8 request_code 72 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)




(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y

Starting program: /usr/bin/gnome-terminal --sync
Error in re-setting breakpoint 1:
No source file named gdkmain-x11.c.
[Thread debugging using libthread_db enabled]
[New Thread 46912519601488 (LWP 9712)]
[New Thread 1084229952 (LWP 9720)]
[Switching to Thread 46912519601488 (LWP 9712)]

Breakpoint 1, gdk_x_error (display=0x86b190, error=0x7fff68c218e0)
    at gdkmain-x11.c:613
613     {
(gdb) where
#0  gdk_x_error (display=0x86b190, error=0x7fff68c218e0) at gdkmain-x11.c:613
#1  0x0000003bee449ca6 in _XError () from /usr/lib64/libX11.so.6
#2  0x0000003bee44b729 in _XReply () from /usr/lib64/libX11.so.6
#3  0x0000003bee44331a in XSync () from /usr/lib64/libX11.so.6
#4  0x0000003bee4434bb in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#5  0x0000003bee43bff0 in XPutImage () from /usr/lib64/libX11.so.6
#6  0x0000003bf4c3c5fd in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#7  0x0000003bf4c3c670 in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#8  0x0000003bf4c1d2cf in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#9  0x0000003bf4c1e160 in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#10 0x0000003bf4c1e39f in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#11 0x0000003bf4c1c088 in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#12 0x0000003bf4c0fc5c in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#13 0x0000003bf4c094fd in cairo_fill_preserve () from /usr/lib64/libcairo.so.2
#14 0x0000003bf4c09519 in cairo_fill () from /usr/lib64/libcairo.so.2
#15 0x00002aaab06482b8 in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#16 0x00002aaab0645475 in g_cclosure_marshal_VOID__OBJECT () at gmarshal.c:614
#17 0x0000003f0473aa92 in gtk_menu_bar_expose (widget=0x88c940, 
    event=0x7fff68c22b70) at gtkmenubar.c:519
#18 0x0000003f047326ed in _gtk_marshal_BOOLEAN__BOXED (closure=0x8d12a0, 
    return_value=0x7fff68c22670, n_param_values=<value optimized out>, 
    param_values=0x7fff68c22770, invocation_hint=<value optimized out>, 
    marshal_data=0x3f0473a930) at gtkmarshalers.c:84
---Type <return> to continue, or q <return> to quit---
#19 0x0000003f02a0af19 in IA__g_closure_invoke (closure=0x8d12a0, 
    return_value=0x7fff68c22670, n_param_values=2, 
    param_values=0x7fff68c22770, invocation_hint=0x7fff68c22630)
    at gclosure.c:490
#20 0x0000003f02a1ad98 in signal_emit_unlocked_R (node=0x8d1550, detail=0, 
    instance=0x88c940, emission_return=0x7fff68c22990, 
    instance_and_params=0x7fff68c22770) at gsignal.c:2478
#21 0x0000003f02a1b99d in IA__g_signal_emit_valist (instance=0x88c940, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fff68c229f0)
    at gsignal.c:2209
#22 0x0000003f02a1bda3 in IA__g_signal_emit (instance=0x86b190, 
    signal_id=1757550816, detail=37748870) at gsignal.c:2243
#23 0x0000003f04830a3e in gtk_widget_event_internal (widget=0x88c940, 
    event=0x7fff68c22b70) at gtkwidget.c:3915
#24 0x0000003f0472cea0 in IA__gtk_main_do_event (event=0x7fff68c22b70)
    at gtkmain.c:1533
#25 0x0000003f03e31fca in gdk_window_process_updates_internal (window=0x943b00)
    at gdkwindow.c:2338
#26 0x0000003f03e3220b in IA__gdk_window_process_all_updates ()
    at gdkwindow.c:2401
#27 0x0000003f046a9665 in gtk_container_idle_sizer (data=<value optimized out>)
    at gtkcontainer.c:1113
#28 0x0000003bf242d1f4 in IA__g_main_context_dispatch (context=0x883a50)
---Type <return> to continue, or q <return> to quit---

Expected results:


Additional info:
Comment 1 John Ellson 2007-03-20 08:49:02 EDT
Thanks for the references.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=231170  provides a work
around that works for me:
    XLIB_SKIP_ARGB_VISUALS=1 gnome-terminal

https://bugs.freedesktop.org/show_bug.cgi?id=10250  indicates that a fix is 
on its way in cairo-1.4.2
Comment 2 John Ellson 2007-03-24 12:51:28 EDT
I'm not seeing this problem now with cairo-1.4.2-1.fc7 installed.  I think this
one can be closed.

Note You need to log in before you can comment on or make changes to this bug.