Bug 233194 - xine-lib not compiled with Freetype support
xine-lib not compiled with Freetype support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-20 16:22 EDT by Bastien Nocera
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 02:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-03-20 16:22:39 EDT
This means that xine-lib can't load fonts listed in Fontconfig (such as the
user's Truetype fonts).

You'll probably want to include 2 of the patches at:
http://xine.cvs.sourceforge.net/xine/xine-lib/src/xine-engine/osd.c?view=log
Revision 1.85 and 1.86

http://xine.cvs.sourceforge.net/xine/xine-lib/src/xine-engine/osd.c?r1=1.84&r2=1.85
http://xine.cvs.sourceforge.net/xine/xine-lib/src/xine-engine/osd.c?r1=1.85&r2=1.86
Comment 1 Ville Skyttä 2007-03-20 18:52:42 EDT
After playing with a bit with various combinations of --with-freetype,
--with-fontconfig and --enable-antialiasing, my humble opinion is that these
options are not ready for prime time (and I guess upstream agrees as none of
them are enabled by default).  I couldn't find a font with which I could get
even acceptably readable subtitles, let alone better looking ones than the
non-freetype ones.  Enabling freetype/fontconfig seems to also screw xine-lib so
that the regular non-freetype fonts that come with it can no longer be selected.

The results I got with freetype/fontconfig looked somewhat like as in
http://farragut.flameeyes.is-a-geek.org/articles/2006/9 , but even less pretty.

I still have the updated package in my working dir and can commit it (making
ft/fontconfig build time optional, disabled by default) if there is demand. 
Aurelien, thoughts?
Comment 2 Aurelien Bompard 2007-03-22 02:46:59 EDT
I'd vote for staying as close to upstream as possible. If they think it's not
ready to be enabled by default, let's just wait till it's done.
Comment 3 Ville Skyttä 2007-03-26 15:58:01 EDT
Since I had the changes around already, I added the --with freetype and --with
antialiasing (both disabled by default) build time flags in 1.1.4-4 in devel.

Note You need to log in before you can comment on or make changes to this bug.