Bug 233456 - Wrong output to display when I use kernel-xen.
Summary: Wrong output to display when I use kernel-xen.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Aron Griffis
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: OtherQA
Depends On: 215536
Blocks: 223107
TreeView+ depends on / blocked
 
Reported: 2007-03-22 15:22 UTC by Andrew
Modified: 2009-06-19 16:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 21:16:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew 2007-03-22 15:22:30 UTC
Description of problem:
I've installed kernel-xen-2.6.18-8.el5.ia64.rpm on HP rx2600. While booting I've
chose it in elilo boot manager, I've saw only 4 lines:

Uncompressing Linux.. done
Loading initrd
Loading vmlinuz
Uncmompressing.. done

Then after a long pause (over 5 minutes) I've get line on the top of screen:
"RV100 113-HP78501-100 BIOS". But later this computer available via ssh.


Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-8.el5

How reproducible:
Every time.

Steps to Reproduce:
1. yum install kernel-xen
2. reboot
3. in elilo boot menu selecting kernel with xen support.

Comment 1 Andrew 2007-03-23 11:47:47 UTC
Hmm.. strange. After several times it have boot normal.
Sorry.

Comment 2 Stephen Tweedie 2007-04-07 20:29:20 UTC
So is this still reproducible at all?  Thanks.


Comment 3 Andrew 2007-04-09 06:28:03 UTC
It seems there are troubles with graphic driver. I've changed runlevel from 5 to
3 and output became correct (note that graphic output is correct with not-xen
kernel).


e0:02.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

Comment 5 Rik van Riel 2007-04-09 07:41:35 UTC
Andrew,

is your video card an AGP card, by any chance?

Comment 6 Andrew 2007-04-09 08:19:12 UTC
Server HP rx2600. I think it's integrated.

Comment 7 Aron Griffis 2007-04-09 21:48:11 UTC
Andrew,

X on dom0 in the RHEL5 IA64 Virtualization Tech Preview does not work.  The
upstream bits came too late to make release.  Since this has been fixed
upstream, I'm hoping to get it fixed in U1.

Your workaround of using runlevel 3 is the best idea for now.

Comment 8 Red Hat Bugzilla 2007-07-25 00:44:14 UTC
change QA contact

Comment 9 Brian Stein 2007-08-03 15:42:10 UTC
Please confirm this is present/fixed in 5.1 beta.

Comment 10 Jarod Wilson 2007-08-07 03:21:04 UTC
I've got multiple ia64 xen boxes where dom0 boots into runlevel 5 just fine, complete with graphics and 
everything -- though bug 240006 still needs to be remedied for some of them to work.

Comment 11 Jarod Wilson 2007-09-11 17:18:53 UTC
I think we can close this one. X is working on rx26x0 systems, as well as a
number of other systems as well. (I've just now tested on an rx2660, rx6600,
zx2000 and intel s6e4533)


Note You need to log in before you can comment on or make changes to this bug.