Bug 233639 - LTC33326: 200901: Update to installation tools - enable the netxen 10Gb Ethernet device as a network boot/install device
LTC33326: 200901: Update to installation tools - enable the netxen 10Gb Ethe...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.6
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: David Lehman
: OtherQA
: 233663 (view as bug list)
Depends On: 235424
Blocks: 203372 232474
  Show dependency treegraph
 
Reported: 2007-03-23 11:24 EDT by IBM Bug Proxy
Modified: 2009-06-19 12:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHBA-2007-0816
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:35:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 33326 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-03-23 11:24:17 EDT
LTC Owner is: sglass@us.ibm.com
LTC Originator is: sglass@us.ibm.com


Feature Id: 200901 

Feature Name: Update to installation tools - enable the netxen 10Gb Ethernet 
device as a network boot/install device. 

Sponsor: PPC 

Category: Device Drivers and IO 

Request Type: Installer - Enhancement from Distributor 

Short Description: netxen (driver name "netxen") is a new 10Gb Ethernet device 
on Blades. This feature is to request an update the distro installers to 
enable it as one of the network boot/install capable devices. 

Describe the Business Case: Support the network boot/install function for 
blades. 

Performance Assistance Required?: no 

Benefits: Support the new blade network device with boot/install function 
enabled. 

Sponsor Priority: 1 

IBM Confidential: yes 

Code Contribution ?: no 

Upstream Acceptance: No Code Required 

Component Release Version Target: 
 
Documentation Work:
 
Reviewed Brand Arch.: Michael Wortman 

Delivery Mechanism LDP Deliverable
Comment 1 IBM Bug Proxy 2007-03-29 11:50:44 EDT
----- Additional Comments From wvoigt@us.ibm.com  2007-03-29 11:45 EDT -------
Wendy, sorry, I miss read this.  This is work for RedHat.  The driver is
submitted in 33290. 
Comment 2 IBM Bug Proxy 2007-04-02 14:38:30 EDT
ltc # 33290 = RH bug # 233504
Comment 3 RHEL Product and Program Management 2007-05-09 01:19:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Chris Lumens 2007-06-01 15:59:13 EDT
dlehman - Fixing this for 5.1 only required adding to the loader2/module-info
file, so hopefully that's all the work that needs to be done here too.
Comment 6 John Jarvis 2007-06-01 17:09:24 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux team
for inclusion in a Red Hat Enterprise Linux minor release.   As a result of this
evaluation, Red Hat has tentatively approved inclusion of this feature in the
next Red Hat Enterprise Linux Update minor release.   While it is a goal to
include this enhancement in the next minor release of Red Hat Enterprise Linux,
the enhancement is not yet committed for inclusion in the next minor release
pending the next phase of actual code integration and successful Red Hat and
partner testing.

Comment 8 Andrius Benokraitis 2007-07-11 16:49:22 EDT
*** Bug 233663 has been marked as a duplicate of this bug. ***
Comment 9 Jarod Wilson 2007-07-11 17:12:17 EDT
Okay, just tested this, at least so far as to start up a network install and be
offered the netxen card as a device to try to install through. I have no install
tree available over that device though, so no means (without some work, that is)
to actually try installing over it.
Comment 13 IBM Bug Proxy 2007-08-29 08:56:07 EDT
------- Comment From sglass@us.ibm.com 2007-08-29 08:51 EDT-------
Since this is in RH cvs tree, moving to Accepted stae
Comment 14 John Poelstra 2007-08-29 13:31:42 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 15 John Poelstra 2007-09-05 18:27:17 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 16 James Laska 2007-09-06 09:11:40 EDT
VERIFIED that the netxen_nic module is included in stage#1 anaconda in
RHEL5.1-Server-20070905.nightly.

2.6.18-44.el5/i686/netxen_nic.ko
2.6.18-44.el5/ia64/netxen_nic.ko
2.6.18-44.el5/ppc64/netxen_nic.ko
2.6.18-44.el5/x86_64/netxen_nic.ko

This will be available in snapshot#6
Comment 17 IBM Bug Proxy 2007-09-14 18:00:25 EDT
------- Comment From pbogdanovic@us.ibm.com 2007-09-14 17:55 EDT-------
In the network device selection menu for a nfs install of RHEL4.6 snap 6 there
are three entries for the two Netxen ports on a blade daughter card.  Two of the
entries are labeled "NetXen Inc. 10Gb ethernet daughter card" (or something
close to that) and the third entry just says "NetXen Inc. unknown device 0024".
We saw a similar issue with the RHEL5.1 installer.
Comment 18 John Poelstra 2007-09-19 22:10:21 EDT
Does IBM consider this issue fixed or still open?(In reply to comment #17)
> ------- Comment From pbogdanovic@us.ibm.com 2007-09-14 17:55 EDT-------
> In the network device selection menu for a nfs install of RHEL4.6 snap 6 there
> are three entries for the two Netxen ports on a blade daughter card.  Two of the
> entries are labeled "NetXen Inc. 10Gb ethernet daughter card" (or something
> close to that) and the third entry just says "NetXen Inc. unknown device 0024".
> We saw a similar issue with the RHEL5.1 installer.

Does IBM consider this issue fixed or still open???
Comment 19 IBM Bug Proxy 2007-10-12 13:30:24 EDT
------- Comment From pair@us.ibm.com 2007-10-12 13:26 EDT-------
This issue is still open from our side. the feature works with some quirks. The
installer is somehow wrongly identifying one of the functions on the netxen PCI
adaptor as a ethernet device, instead of ignoring it. If the user picks up that
device for netinstall, the installer fails. But its not terribly bad, because
the user can continue by then picking up the other device.

We have been talking to Netxen on this issue, and they think the installer is
misbehaving.
Comment 20 Suzanne Yeghiayan 2007-10-12 16:32:57 EDT
Since the feature represented by this bugzilla works as per comment 19,
returning bugzilla to status VERIFIED.
Please enter separate bugzillas to report the quirks found.

Thank you.
Comment 22 errata-xmlrpc 2007-11-15 11:35:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0816.html

Note You need to log in before you can comment on or make changes to this bug.