Bug 23367 - 3DLabs video driver not working properly under XFree86 v.4
3DLabs video driver not working properly under XFree86 v.4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
alpha Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-04 20:36 EST by Michael Williams
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 13:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Williams 2001-01-04 20:36:17 EST
The problem is that whenever I start an application under X windows
especially Netscape the fonts mess up and the colors start turning black
when windows are moved. Netscape actually locks the machine up with some
sort of weird video problem. I've tried various video resolutions and color
depths but they all do it. 

A workaround for the problem seem to be that Red Hat 7 uses the X 4.0 
video drivers. The 3.0 video drivers are also on the
distribution disks. When I install those RPMs and use Xconfigurator with 
the
--preferxf3 switch. Then I  restart the X server everything starts working 
ok again.
Comment 1 Mike A. Harris 2001-01-28 13:06:54 EST
This sounds similar to <A
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=24026">Bug 24026</A>.

Could you check and see if it describes the same problem you're seeing,
perhaps in different words?
Comment 2 Michael Williams 2001-01-28 18:27:54 EST
I dont think this problem is related to bug 24026. The problem I am seeing is 
much more severe to the point that the graphical installion does not work at 
all on the Alpha which forces the use of the text mode install. Also once X 
windows doesnt start again the problem is so severe that the system becomes 
totally unusable in the X windows environment.
Comment 3 Mike A. Harris 2001-02-26 17:37:15 EST
Possible fix in the works..
Comment 4 Mike A. Harris 2001-02-26 17:37:33 EST
Possible fix in the works..
Comment 5 Mike A. Harris 2001-03-19 21:31:24 EST
Can you try out XFree86-4.0.3 from:

ftp://people.redhat.com/mharris

Does it fix the problem for you?
Comment 6 Mike A. Harris 2001-04-02 09:55:03 EDT
If you'd like this bug fixed in our next release, please supply me with the
ALL of the following information ASAP.  I need copies of your X server logs,
as well as your config file, and the output of "lspci -v", and "lspci -vn",
all as file attachments.  Also I need your /proc/cpuinfo also.

The sooner you send me the info, the sooner I can pull the required
portions out of the patches I just received from Compaq.  I do not have
an alpha or permedia to test with here, so I'm hoping you can supply the
info and test the patches out while I still have time to include new stuff
in our next Alpha release.
Comment 7 Mike A. Harris 2001-04-10 01:02:00 EDT
A *MAJOR* new update to the Permedia driver has just been incorporated
into XFree86-4.0.3-8.  The patches are from Compaq, and fix numerous
problems on Alpha, as well as other platforms.  These packages are available
for download at:   http://people.redhat.com/mharris
Please close the bug report after confirming that it does in fact fix the
problem for you, and ensure that you fill out new bug reports if you encounter
any new errors.  Thanks.
Comment 8 Mike A. Harris 2001-04-13 13:55:54 EDT
I mistakenly gave a bad URL above.  ;o(  The proper URL is:

ftp://people.redhat.com

Not http.  Please try out the latest code and let me know if this problem is
fixed now.
Comment 9 Mike A. Harris 2001-04-19 16:35:10 EDT
Problem solved in Rawhide version 4.0.3-8 and higher.
Current release is 4.0.3-9

Note You need to log in before you can comment on or make changes to this bug.