Bug 233710 - Tape test fails with AttributeError
Tape test fails with AttributeError
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
:
: 233711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 18:06 EDT by Keith Orsak
Modified: 2008-07-16 17:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 10:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Orsak 2007-03-23 18:06:43 EDT
Description of problem:

When running a tape test the test always fails because of an AttributeError.  
Here is the output that I receive while running the test:

Tape test is running, please be patient ... 
...finished running ./tape.sh, exit code=0
recovered exit code=0
rhts-report-result /HTS/hts/tape PASS /var/log/hts/runs/1/tape/output.log 
saveOutput: /var/log/hts/runs/1/tape/output.log
Return value was 0
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 67, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 260, in 
doCertify
    if test.isDisabled():
AttributeError: 'list' object has no attribute 'isDisabled'

Version-Release number of selected component: HTS-5.0-31


How reproducible:  This error has occurred on every tape test that I have run 
on three different servers ((1)IA64, (2)i386) for three different tape drives.

Steps to Reproduce:

1.  Disable the firewall in Red Hat 5.
2.  Enable SELinux targeting policy with Enforcing on.
3.  Turn off the server and plug in the tape drive.
4.  Reboot the computer.
3.  Open a terminal and start server (root->hts server start)
4.  Create test plan (root>hts plan)  
5.  Run the tape test (root>hts certify --test=tape)

Actual results:

Tape test is running, please be patient ... 
...finished running ./tape.sh, exit code=0
recovered exit code=0
rhts-report-result /HTS/hts/tape PASS /var/log/hts/runs/1/tape/output.log 
saveOutput: /var/log/hts/runs/1/tape/output.log
Return value was 0
Traceback (most recent call last):
  File "/usr/bin/hts", line 113, in ?
    success = hts.do(args)
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 67, in do
    return self.doCertify()
  File "/usr/lib/python2.4/site-packages/hts/hardwaretest.py", line 260, in 
doCertify
    if test.isDisabled():
AttributeError: 'list' object has no attribute 'isDisabled'

Expected results:


Additional info:
Comment 1 Keith Orsak 2007-03-23 18:14:26 EDT
*** Bug 233711 has been marked as a duplicate of this bug. ***
Comment 2 YangKun 2007-03-27 01:27:06 EDT
please provide(attach) following three files here:
  1) "/var/hts/config.xml"
  2) "/var/hts/plan.xml"
  3) "/var/hts/results.xml"

If the "/var/hts/results.xml" file is not exist, then please run the following
command:
  # tar -jcvf /root/var-log-hts.tar.bz2 /var/log/hts

and then attach the "/root/var-log-hts.tar.bz2" file here.

thanks
Comment 3 Keith Orsak 2007-03-27 10:32:37 EDT
For some reason I cannot reproduce this issue now.  I installed R32 on one of 
the two servers that I received this error on but both seem to be running the 
test fine now.  It may have been a server issue but if I run into this problem 
again I will let you know.  Thank you.

-Keith

(In reply to comment #2)
> please provide(attach) following three files here:
>   1) "/var/hts/config.xml"
>   2) "/var/hts/plan.xml"
>   3) "/var/hts/results.xml"
> If the "/var/hts/results.xml" file is not exist, then please run the 
following
> command:
>   # tar -jcvf /root/var-log-hts.tar.bz2 /var/log/hts
> and then attach the "/root/var-log-hts.tar.bz2" file here.
> thanks


Note You need to log in before you can comment on or make changes to this bug.