Bug 23372 - webxref should set Host header in HTTP request
webxref should set Host header in HTTP request
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: webxref (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-04 22:46 EST by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-06 09:50:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make webxref set Host: header in HTTP requests (280 bytes, patch)
2001-01-04 22:46 EST, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2001-01-04 22:46:26 EST
When webxref sends a HTTP request to a server to verify whether a given URL
is valid, it should set the "Host:" header in the request, because
otherwise some servers (e.g., ones that are sitting behind proxies) won't
be able to process it.

I'll attach a patch.  The fix is very simple.
Comment 1 Jonathan Kamens 2001-01-04 22:46:48 EST
Created attachment 7084 [details]
patch to make webxref set Host: header in HTTP requests
Comment 2 Tim Powers 2001-01-06 09:50:02 EST
I applied the patch included in this report as well as the other patches you
submitted. You should see the unified patch in the webxref-0.3.5-12 package
located in rawhide the next time rawhide gets an update. I am resolving this as
"rawhide".

Tim

Note You need to log in before you can comment on or make changes to this bug.