Bug 233744 - Invalid pipeline
Invalid pipeline
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: istanbul (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
: 234437 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 10:31 EDT by Andrew Clayton
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 22:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Clayton 2007-03-24 10:31:29 EDT
Description of problem:

When running instabul, it seems to get the start of the pipeline messed up.
e.g
$ istanbul 
DEBUG: final pipeline: istximagesrc name=videosource show-pointer=false !
video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale
method=1 ! video/x-raw-yuv,width=350,height=262,framerate=10/1 ! theoraenc !
oggmux name=mux ! filesink location=/tmp/tmpf08BUV

[snip rest of error]

istximagesrc should probably be just ximagesrc as running this from the shell works:
gst-launch ximagesrc name=videosource show-pointer=false !
video/x-raw-rgb,framerate=10/1 ! videorate ! ffmpegcolorspace ! videoscale
method=1 ! video/x-raw-yuv,width=350,height=262,framerate=10/1 ! theoraenc !
oggmux name=mux ! filesink location=/tmp/screencast.ogg

Version-Release number of selected component (if applicable):

istanbul-0.2.1-0.fc6

How reproducible:

100%

Steps to Reproduce:
1.

Run istanbul

2.
3.
  
Actual results:

Error, fails to capture screen.

Expected results:

Screen capture

Additional info:
Comment 1 Jef Spaleta 2007-03-24 15:10:00 EDT
istximagesrc is a valid plugin

gst-inspect |grep istx
istximagesrc:  istximagesrc: Ximage video source

gst-inspect istximagesrc|less
In fact istanbul does a check for its existance in main.py

I'm not sure why istximagesrc wouldn't work when ximagesrc does. Did you confirm
that the istximagesrc pipeline doesn't work at the cmdline?

-jef
Comment 2 Jef Spaleta 2007-03-24 15:17:39 EDT
okay first thing,  upstream has released a new version of istanbul in feb that I
didn't catch. So I'll going to push that into fedora extras development, and fc6.
If the new upstream version still has a reproducible problem for you, we can get
on the upstream gnome bugzilla and talk to the istanbul developers about it.

-jef
Comment 3 Andrew Clayton 2007-03-24 17:07:04 EDT
$ gst-launch istximagesrc name=videosource ! video/x-raw-rgb,framerate=10/1 !
videorate ! ffmpegcolorspace ! videoscale method=1 !
video/x-raw-yuv,width=1400,height=1050,framerate=10/1 ! theoraenc ! oggmux
name=mux ! filesink location=/tmp/tmp6j6d0k
WARNING: erroneous pipeline: could not link videorate0 to ffmpegcsp0

I'll retest with the updated version.

Cheers,
Comment 4 Jef Spaleta 2007-03-24 18:34:18 EDT
an official update is going to take longer than i thought..due to some new
dependencies which I'll need to get into the fedora repository before I can
build the new istanbul.  But I will make available for testing a set of
unoffocial packages for you to test.

One thing, if you turn off sound recording, 3d recording and mouse pointer
recording does the error still happen?

Were you doing full screen captures or did you select an area of the screen to
capture?

-jef
Comment 5 Andrew Clayton 2007-03-24 19:38:18 EDT
(In reply to comment #4)

> 
> One thing, if you turn off sound recording, 3d recording and mouse pointer
> recording does the error still happen?

Yeah.
 
> Were you doing full screen captures or did you select an area of the screen to
> capture?

Tried both.
 
> -jef

Comment 6 Jef Spaleta 2007-03-24 23:24:17 EDT
A build of the new istanbul and the new requirment python-xlib for FC6
can be found at:
http://jspaleta.thecodergeek.com/Fedora%20SRPMS/istanbul/0.2.2-FC6-test/

And a build against fedora development can be found at:
http://jspaleta.thecodergeek.com/Fedora%20SRPMS/istanbul/0.2.2-development-test/

please try the new istanbul out. I want to find a situation that I can reproduce
on my development system. Running either version of istanbul on my system works
if I turn off the sound recording.  Full screen, reasonable screen area, and
window selection all record for me if i disable sound in the new version.  

I can also show you how to patch istanbul directly, to switch it to using
ximagesrc instead of istximagesrc.  Which might be a good idea for you to do a
test, to prepare for a discussion with upstream developers.

-jef
Comment 7 Andrew Clayton 2007-03-25 08:16:24 EDT
OK, I tried your FC6 rpms and it worked first time!

(It has a save dialogue, which is handy, never got that far before!)

Just to make sure, I removed these new packages and reinstalled the old istanbul
and tried again.

With no sound, no mouse poinyer, no 3d, quarter size. 

I start the recording, icon goes from red to black. And get this error:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/istanbul/main/tray_icon.py", line 56,
in _trayicon_clicked
    self.current_screencast.start_recording()
  File "/usr/lib/python2.4/site-packages/istanbul/main/screencast.py", line 109,
in start_recording
    self._pipeline = gst.parse_launch(final_pipeline)
gobject.GError: could not link videorate0 to ffmpegcsp0

I then click the icon to stop recording. Icond turns into a disk or something
and I get this error:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/istanbul/main/tray_icon.py", line 62,
in _trayicon_clicked
    self.current_screencast.stop_recording()
  File "/usr/lib/python2.4/site-packages/istanbul/main/screencast.py", line 136,
in stop_recording
    self._vsource.set_state(gst.STATE_NULL)
AttributeError: Screencast instance has no attribute '_vsource'

The icon is now unresponsive and I have to Ctrl-c it.

Btw, I'm pretty sure I get this same problem on my AMD64 machine (FC6) at work,
just never looked into in this much detail.


Just for a final test, I switched back to the updated packages and tried again,
still works, and with mouse pointer recording and at full size too!

Will these new packages make it into FC6?


Thanks for your time.
Andrew
Comment 8 Jef Spaleta 2007-03-25 17:51:58 EDT
There is a new dependency, python-xlib, which needs to get into the Fedora
software collection before I can update.  As soon as that package submission
passes review and is built for FC-6 I'll have istanbul updated in both
development and FC-6.  I'm hoping it will just take a week, but it might take a
little longer depending on when a reviewer goes over the python-xlib submission.


-jef
Comment 9 Jef Spaleta 2007-03-29 13:27:38 EDT
*** Bug 234437 has been marked as a duplicate of this bug. ***
Comment 10 Jef Spaleta 2007-04-11 01:22:58 EDT
Okay just an update.
python-xlib has made it past review once that is built I will be able to update
istanbul in fc-6 at least.

There is a catch however. development is currently in a freeze state, so I am
going to have to make a request to release engineering to let an update to
istanbul in.

Is anyone other than myself currently running a fedora development install and
can do some istanbul functionality testing?  I can make test builds of the new
istanbul version available for others to test. If I can have a couple of other
people test both fc6 and devel boxes and reporting on any regressions (or lack
thereof) it will make for a better argument to let istanbul get updated into the
devel tree post-freeze.

Once i get python-xlib built (in the next couple of days) I'll be looking hard
for testers for istanbul packagesfor both fc6 and devel.

-jef
Comment 11 Jef Spaleta 2007-04-16 22:30:28 EDT
Okay new version of istanbul just got built in Extras. It should be available
for consumption in the next couple of days. Please test the new update and
re-open this bug if the reported problem persists in the istanbul-0.2.2-2.fc6 build.


-jef

Note You need to log in before you can comment on or make changes to this bug.