Bug 233797 - Keyboard becomes useless after Shift Lock keys
Keyboard becomes useless after Shift Lock keys
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 23:00 EDT by Allen Kistler
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.21-1.3194.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 22:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for kernel 2.6.20-1.3045.fc7 (16.72 KB, text/plain)
2007-04-06 18:45 EDT, Allen Kistler
no flags Details

  None (edit)
Description Allen Kistler 2007-03-24 23:00:22 EDT
Description of problem:
Pressing CapsLock, NumLock, or ScrollLock causes the keyboard to become
unresponsive and the Lock LEDs to flash.  The run level is 3.

Version-Release number of selected component (if applicable):
2.6.20-1.2997.fc7
2.6.20-1.3017.fc7

How reproducible:
Always

Steps to Reproduce:
1. Press a Lock key at any time after boot
  
Actual results:
LEDs on keyboard flash.  No other keypress is ever recognized again.

Expected results:
Lock state should be set or reset, depending upon current state.

Additional info:
The machine itself responds to network events.  I can ssh in and reboot the
machine, which is the only way to get the keyboard back.  The problem does not
exist with kernel-2.6.20-1.2949.fc7.

I'm not certain it's totally the kernel at fault, but the only variable between
working and not working is the kernel version.  I have updated everything else
to the latest in rawhide.  (The problem also exhibits with everything but the
kernel at the levels in the f7-test2 distro.)  The keyboard/mouse is PS/2 using
a Tripp-Lite PS/2-to-USB adapter.  The PC is a Dell Optiplex 320, which has only
USB ports for mouse and keyboard.
Comment 1 Pete Zaitcev 2007-03-24 23:14:08 EDT
Please attach a dmesg taken when you ssh into the box for reboot.
Please do it even if it looks entirely normal (e.g. no oops).

I'm quite sure that you're right blaming the kernel, especially
if last-working version is known.
Comment 2 Allen Kistler 2007-04-06 18:45:17 EDT
Created attachment 151900 [details]
dmesg for kernel 2.6.20-1.3045.fc7
Comment 3 Allen Kistler 2007-04-06 18:57:21 EDT
As you can see from the last comment, the problem still exists in the 3045 build
(so it hasn't magically gone away).  FWIW, unplugging and replugging the USB
doesn't help, but here are the entries from messages after I tried twice:

kernel: usb 2-2: USB disconnect, address 3
kernel: usb 2-2: new low speed USB device using ohci_hcd and address 4
kernel: usb 2-2: configuration #1 chosen from 1 choice
kernel: input: ATEN ATEN Composite as /class/input/input6
kernel: input: USB HID v1.10 Keyboard [ATEN ATEN Composite] on usb-0000:00:13.1-2
kernel: input: ATEN ATEN Composite as /class/input/input7
kernel: input: USB HID v1.10 Mouse [ATEN ATEN Composite] on usb-0000:00:13.1-2
kernel: usb 2-2: USB disconnect, address 4
kernel: usb 2-2: new low speed USB device using ohci_hcd and address 5
kernel: usb 2-2: configuration #1 chosen from 1 choice
kernel: input: ATEN ATEN Composite as /class/input/input8
kernel: input: USB HID v1.10 Keyboard [ATEN ATEN Composite] on usb-0000:00:13.1-2
kernel: input: ATEN ATEN Composite as /class/input/input9
kernel: input: USB HID v1.10 Mouse [ATEN ATEN Composite] on usb-0000:00:13.1-2
Comment 4 Allen Kistler 2007-04-14 15:13:07 EDT
BZ appears not to want to let me change the status back to Assigned from
Needinfo, so I'm changing Needinfo to the Asignee.
Comment 5 Allen Kistler 2007-05-20 03:11:54 EDT
I kind of tuned out after f7t4 continued to exhibit this bug.

FWIW, somewhere between kernel-2.6.20-1.3104.fc7 (the f7t4 kernel, as
distributed on the ISOs) and kernel-2.6.21-1.3163.fc7 (rawhide as of now), the
bug has gone away.
Comment 6 Allen Kistler 2007-05-27 03:52:29 EDT
The bug is still missing in kernels 3189 and 3194.
Here's hoping it continues to be missing in the general release....
Comment 7 Allen Kistler 2007-06-01 22:40:16 EDT
Since 3194 is what's on the final media (and doesn't have the bug), I'm closing
this item (hopefully never to be re-opened, eh?).

Note You need to log in before you can comment on or make changes to this bug.