This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 233828 - crossfire-*: unowned directory
Summary: crossfire-*: unowned directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: crossfire-client (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Wart
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-25 10:58 UTC by Michael Schwendt
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 05:25:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2007-03-25 10:58:30 UTC
The directory is only included in the "crossfire" package without
a dependency on it:

=> crossfire-client - 1.9.1-3.fc7.i386
/usr/share/crossfire

=> crossfire-client-images - 1.9.1-3.fc7.i386
/usr/share/crossfire

=> crossfire-maps - 1.9.1-2.fc6.noarch
/usr/share/crossfire

Comment 1 Wart 2007-05-21 20:04:24 UTC
Adding a dependency on 'crossfire' from 'crossfire-client' and these others is
not really acceptable, since the client and server packages are not
interdependent (except for this directory).

I could either have multiple packages provide the /usr/share/crossfire
directory, or create a crossfire-filesystem package that contains only this one
directory.

Do you have a preference?

Comment 2 Michael Schwendt 2007-07-05 23:34:43 UTC
Don't make me regret that I've filed lots of tickets about
unowned directories. I have no particular interest in crossfire*,
but as long as it is possible with rpm to install unowned
directories with insufficient file access permission bits,
they remain a source of run-time problems.

A crossfire-filesystem package for a single empty dir would be
ridiculous, especially when it would use default %defattr.

If client and server don't share common files in that directory
and don't use it to exchange files either, how about creating
separate directories for separate packages?

/usr/share/crossfire/
/usr/share/crossfire-client/

What does upstream say? And how does crossfire-maps fit into the
dependency scheme?

There are several ways how to fix this, and making all sub-packages
own the same directory would work as a last resort.


Comment 3 Wart 2007-07-13 17:18:52 UTC
I took a closer look at the directory layout and have started testing some
packages that fix these unowned directory issues.  I need to finish testing some
additional selinux fixes before I will push an update.

Comment 4 Wart 2007-07-18 05:25:24 UTC
Fixed in rawhide.  I'll push updates to F-7 at the same time that I upgrade F-7
to the latest crossfire release.


Note You need to log in before you can comment on or make changes to this bug.