Bug 233956 - udev firewire rules conflict with raw devices
udev firewire rules conflict with raw devices
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-26 07:14 EDT by Bryn M. Reeves
Modified: 2010-10-22 10:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0404
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 13:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-03-26 07:14:35 EDT
Description of problem:
The 1394th raw device node is /dev/raw/raw1394 and the device has a kernel name
of raw1394. IEEE1394 (firewire) allows raw access to the 1394 protocol using a
device which also has a kernel name of raw1394.

Attempting to create /dev/raw/raw1394 via a command like:

# raw /dev/raw/raw1394 /dev/<bdev>

ends up creating /dev/raw1394 instead, because of the following line in
50-udev.rules:

# IEEE1394 (firewire) devices (must be before raw devices below)
KERNEL=="raw1394",              NAME="%k"

This needs to be more specific, for example:

SUBSYSTEM=="ieee1394_protocol", KERNEL=="raw1394",       NAME="%k"

Version-Release number of selected component (if applicable):
udev-095-17.fc6, udev-095-14.5.el5

How reproducible:
100%

Steps to Reproduce:
1. raw /dev/raw/raw1394 /dev/<bdev>
  
Actual results:
/dev/raw1394 is created.

Expected results:
/dev/raw/raw1394 is created.
Comment 5 Harald Hoyer 2007-06-13 08:14:46 EDT
You may try:
http://people.redhat.com/harald/downloads/udev/udev-095-14.9.el5/
Comment 9 errata-xmlrpc 2007-11-07 13:08:14 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0404.html

Note You need to log in before you can comment on or make changes to this bug.