Bug 233968 - Broadcom NetXtreme broken on 64-bit kernel 2.6.19+
Broadcom NetXtreme broken on 64-bit kernel 2.6.19+
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-26 08:26 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.20-1.2944.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 19:23:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-03-26 08:26:09 EDT
Description of problem: 
No network when using kernel-2.6.20-* x86_64 (and kernel-2.6.19-* x86_64)

Version-Release number of selected component (if applicable):
Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v1.5.5 (February 1, 2007)

How reproducible:
Allways


Steps to Reproduce:
1.Boot the machine
2.The machine boots but no network

  
Actual results:
No network

Expected results:
A working network

Additional info:
Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v1.4.44 (August 10,
2006)kernel-2.6.18-* x86_64 is OK. AND FOR SOME REASON ALSO ALL ABOWNAMED
KERNELS ARE OK WHEN 32-BIT-KERNEL VERSIONS.
Comment 1 Chuck Ebbert 2007-03-26 14:58:38 EDT
Exactly which model of adapter is this?

Please post results of "lspci -n" command.
Comment 2 Need Real Name 2007-03-26 15:28:28 EDT
(In reply to comment #1)
> Exactly which model of adapter is this?

eth0: Broadcom NetXtreme II BCM5708 1000Base-T (B1)
 PCI-X 64-bit 133MHz

> 
> Please post results of "lspci -n" command.
> 

[root@vara log]# uname -a
Linux vara.haapavedenapteekki 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:34 EST
2006 x86_64 x86_64 x86_64 GNU/Linux
[root@vara log]#

[root@vara log]# /sbin/lspci -n
00:00.0 0600: 8086:25c0 (rev 12)
00:02.0 0604: 8086:25e2 (rev 12)
00:03.0 0604: 8086:25e3 (rev 12)
00:04.0 0604: 8086:25e4 (rev 12)
00:05.0 0604: 8086:25e5 (rev 12)
00:06.0 0604: 8086:25f9 (rev 12)
00:07.0 0604: 8086:25e7 (rev 12)
00:10.0 0600: 8086:25f0 (rev 12)
00:10.1 0600: 8086:25f0 (rev 12)
00:10.2 0600: 8086:25f0 (rev 12)
00:11.0 0600: 8086:25f1 (rev 12)
00:13.0 0600: 8086:25f3 (rev 12)
00:15.0 0600: 8086:25f5 (rev 12)
00:16.0 0600: 8086:25f6 (rev 12)
00:1c.0 0604: 8086:2690 (rev 09)
00:1d.0 0c03: 8086:2688 (rev 09)
00:1d.1 0c03: 8086:2689 (rev 09)
00:1d.2 0c03: 8086:268a (rev 09)
00:1d.3 0c03: 8086:268b (rev 09)
00:1d.7 0c03: 8086:268c (rev 09)
00:1e.0 0604: 8086:244e (rev d9)
00:1f.0 0601: 8086:2670 (rev 09)
00:1f.1 0101: 8086:269e (rev 09)
01:00.0 0604: 8086:0370
01:00.2 0604: 8086:0372
02:0e.0 0104: 1028:0015
04:00.0 0604: 1166:0103 (rev c2)
05:00.0 0200: 14e4:164c (rev 11)
06:00.0 0604: 8086:3500 (rev 01)
06:00.3 0604: 8086:350c (rev 01)
07:00.0 0604: 8086:3510 (rev 01)
07:01.0 0604: 8086:3514 (rev 01)
08:00.0 0604: 1166:0103 (rev c2)
09:00.0 0200: 14e4:164c (rev 11)
10:0d.0 0300: 1002:515e (rev 02)
[root@vara log]#
Comment 3 Chuck Ebbert 2007-03-26 15:48:18 EDT
Can you post contents of /proc/interrupts?

Comment 4 Need Real Name 2007-03-27 06:42:10 EDT
FIRST THE /proc/interrupts WITH THE KERNEL-2.6.18*:

[ingres@vara ~]$ uname -a
Linux vara.haapavedenapteekki 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:34 EST
2006 x86_64 x86_64 x86_64 GNU/Linux
[ingres@vara ~]$

[ingres@vara ~]$ more /proc/interrupts
           CPU0       CPU1       CPU2       CPU3
  0:    6263091          0          0          0    IO-APIC-edge  timer
  6:          5          0          0          0    IO-APIC-edge  floppy
  8:          1          0          0          0    IO-APIC-edge  rtc
  9:          0          0          0          0   IO-APIC-level  acpi
 14:      55976          0          0          0    IO-APIC-edge  ide0
 66:        671          0          0          0   IO-APIC-level  uhci_hcd:usb1,
 uhci_hcd:usb3, ehci_hcd:usb5
 74:        174          0          0          0   IO-APIC-level  uhci_hcd:usb2,
 uhci_hcd:usb4
 82:      12055       5855          0          0   IO-APIC-level  megasas
 90:       2175          0          0          0         PCI-MSI  eth0
NMI:        270         71         71         71
LOC:    6262645    6262520    6262501    6262378
ERR:          0
MIS:          0
[ingres@vara ~]$

AND HERE ARE THE lspci -n AND /proc/interrupts WITH THE NOT WORKING KERNEL-2.6.20*:

[ingres@vara ~]$ uname -a
Linux vara.haapavedenapteekki 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:00:19 EDT 2
007 x86_64 x86_64 x86_64 GNU/Linux
[ingres@vara ~]$

[ingres@vara ~]$ /sbin/lspci -n
00:00.0 0600: 8086:25c0 (rev 12)
00:02.0 0604: 8086:25e2 (rev 12)
00:03.0 0604: 8086:25e3 (rev 12)
00:04.0 0604: 8086:25e4 (rev 12)
00:05.0 0604: 8086:25e5 (rev 12)
00:06.0 0604: 8086:25f9 (rev 12)
00:07.0 0604: 8086:25e7 (rev 12)
00:10.0 0600: 8086:25f0 (rev 12)
00:10.1 0600: 8086:25f0 (rev 12)
00:10.2 0600: 8086:25f0 (rev 12)
00:11.0 0600: 8086:25f1 (rev 12)
00:13.0 0600: 8086:25f3 (rev 12)
00:15.0 0600: 8086:25f5 (rev 12)
00:16.0 0600: 8086:25f6 (rev 12)
00:1c.0 0604: 8086:2690 (rev 09)
00:1d.0 0c03: 8086:2688 (rev 09)
00:1d.1 0c03: 8086:2689 (rev 09)
00:1d.2 0c03: 8086:268a (rev 09)
00:1d.3 0c03: 8086:268b (rev 09)
00:1d.7 0c03: 8086:268c (rev 09)
00:1e.0 0604: 8086:244e (rev d9)
00:1f.0 0601: 8086:2670 (rev 09)
00:1f.1 0101: 8086:269e (rev 09)
01:00.0 0604: 8086:0370
01:00.2 0604: 8086:0372
02:0e.0 0104: 1028:0015
04:00.0 0604: 1166:0103 (rev c2)
05:00.0 0200: 14e4:164c (rev 11)
06:00.0 0604: 8086:3500 (rev 01)
06:00.3 0604: 8086:350c (rev 01)
07:00.0 0604: 8086:3510 (rev 01)
07:01.0 0604: 8086:3514 (rev 01)
08:00.0 0604: 1166:0103 (rev c2)
09:00.0 0200: 14e4:164c (rev 11)
10:0d.0 0300: 1002:515e (rev 02)
[ingres@vara ~]$

[ingres@vara ~]$ more /proc/interrupts
           CPU0       CPU1       CPU2       CPU3
  0:     166547          0          0          0   IO-APIC-edge      timer
  1:          2          0          0          0   IO-APIC-edge      i8042
  6:          5          0          0          0   IO-APIC-edge      floppy
  8:          1          0          0          0   IO-APIC-edge      rtc
  9:          0          0          0          0   IO-APIC-fasteoi   acpi
 12:          4          0          0          0   IO-APIC-edge      i8042
 14:       1235          0          0          0   IO-APIC-edge      ide0
 20:        328          3          0          0   IO-APIC-fasteoi   uhci_hcd:us
b2, uhci_hcd:usb4
 21:        181          5          0          0   IO-APIC-fasteoi   uhci_hcd:us
b1, uhci_hcd:usb3, ehci_hcd:usb5
142:       6858       8734          0          0   IO-APIC-fasteoi   megasas
2294:         63          0          0          0   PCI-MSI-edge      eth0
NMI:          0          0          0          0
LOC:     166099     166023     165955     165881
ERR:          0
[ingres@vara ~]$

The machine is Dell PowerEdge 2900 Server. BIOS is version 1.2.0.
The PowerEdge™ 2900 has a dual embedded Broadcom® NetXtreme II 5708 Gigabit
Ethernet NIC. TCP/IP Offload Engine (TOE) is included in the Broadcom 5708 LOM
feature set and is enabled. Both ports and Offload Engine are enabled in BIOS,
but only one port is enabled when "booted" (system-config-network).
Comment 5 Chuck Ebbert 2007-03-27 14:17:48 EDT
Can you try disabling TOE? Also try booting with "pci=nomsi" kernel option.
Comment 6 Chuck Ebbert 2007-03-28 10:19:56 EDT
Using pci=nomsi fixes the problem (reported via email.)

Leaving bug open for tracking since it's not really fixed.
Comment 7 Chuck Ebbert 2007-03-30 18:04:00 EDT
We are going to make pci=nomsi the default on the next kernel update.

Note You need to log in before you can comment on or make changes to this bug.