Bug 234006 - system-config-kickstart dies on startup
system-config-kickstart dies on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-26 12:22 EDT by Zack Cerza
Modified: 2014-01-21 17:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 13:49:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback; /var/tmp/yum-test-RtsSod/ is empty. (1.48 KB, text/plain)
2007-03-26 12:22 EDT, Zack Cerza
no flags Details
system-config-kickstart debug output (1.10 KB, text/plain)
2007-04-20 17:54 EDT, Christopher Brown
no flags Details

  None (edit)
Description Zack Cerza 2007-03-26 12:22:18 EDT
Description of problem:
s-c-kickstart crashes on startup with a traceback if started via the menu. It
appears to start up successfully if launched from a terminal.

Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.4-1.fc7

How reproducible:
Always
Comment 1 Zack Cerza 2007-03-26 12:22:18 EDT
Created attachment 150910 [details]
traceback; /var/tmp/yum-test-RtsSod/ is empty.
Comment 2 Zack Cerza 2007-03-26 12:27:47 EDT
Comment on attachment 150910 [details]
traceback; /var/tmp/yum-test-RtsSod/ is empty.

sigh, it's a freaking text file, bugzilla :P
Comment 3 Zack Cerza 2007-03-26 12:33:39 EDT
Oh, heh, actually the failure is causes by being non-root.
Comment 4 Chris Lumens 2007-03-27 14:38:44 EDT
I'm seeing this with repoquery as well.
Comment 5 Christopher Brown 2007-04-20 17:54:30 EDT
Created attachment 153219 [details]
system-config-kickstart debug output
Comment 6 Christopher Brown 2007-04-20 17:55:09 EDT
Also seeing this. See attached debug output.
Comment 7 Chris Lumens 2007-04-23 10:37:23 EDT
Christopher - that is a different bug than the one originally addressed in this
report, and is tracked by bug 236999.
Comment 8 Jeremy Katz 2007-04-24 18:01:02 EDT
This is fixed with CVS yum, at least the main part.  

I then get a different traceback since you've enabled the core repo which ends
up with a releasever of 6.92 and there isn't a valid mirrorlist for that. 
You're either going to need to 
  1) catch the RepoError in doRepoSetup()
  2) or individually setup the repos when you enable them (repo.setup())
Comment 9 Chris Lumens 2007-04-25 13:49:18 EDT
We weren't able to reproduce this on today's rawhide, so I'm closing this out.

Note You need to log in before you can comment on or make changes to this bug.