Bug 234112 - Can not submit testing results if harness doesn't find machine's "model"
Summary: Can not submit testing results if harness doesn't find machine's "model"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: YangKun
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 230244 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-27 03:40 UTC by YangKun
Modified: 2007-08-02 16:30 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0736
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 16:30:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var-hts.tar.bz2 (113.08 KB, application/x-bzip2)
2007-03-27 03:40 UTC, YangKun
no flags Details
var-log-hts.tar.bz2 (4.74 MB, application/x-bzip2)
2007-03-27 03:47 UTC, YangKun
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0736 normal SHIPPED_LIVE hts bug fix available 2007-10-24 15:32:42 UTC

Description YangKun 2007-03-27 03:40:37 UTC
Description of problem:
When running HTS R32 on a DIYed machine, HTS can not find system's model, this
leads to an error when running "hts submit". Can we provide some default
values(e.g.: "unknown") to "vendor" and "model" and "make" if the harness can
not find them from system's BIOS, because for some machines(especially for some
DIYed machines), these three info may not always be available(though we can find
them on most IHV's machines).  

Following are error logs:
------------------------------------------------------------
[root@dhcp-0-082 ~]# hts submit
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml
loaded results /var/hts/results.xml
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/0': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/0/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/AUDIO/0': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/0/AUDIO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/1': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/1/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/CORE/1': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/1/CORE: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/2': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/2/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/MEMORY/2': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/2/MEMORY: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/3': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/3/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/NETWORK/3': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/3/NETWORK: No such
file or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/4': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/4/INFO: No such file
or directory
copying attachments...
copying attachments...
copying attachments...
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/STORAGE/4': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/4/STORAGE: No such
file or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/5': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/5/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/USB/5': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/5/USB: No such file or
directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/INFO/6': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/6/INFO: No such file
or directory
copying attachments...
ln: creating symbolic link `/var/log/hts/hts-Intel_Corp.-' to
`../../tests/VIDEO/6': File exists
sh: line 1: ____-Tikanga5_x86_64_results/var/log/hts/runs/6/VIDEO: No such file
or directory
tar: Cowardly refusing to create an empty archive
Try `tar --help' or `tar --usage' for more information.
Error: tar command failed
Error: failed to generate results rpm
[root@dhcp-0-082 ~]#
------------------------------------------------------------

Comment 1 YangKun 2007-03-27 03:40:37 UTC
Created attachment 150996 [details]
var-hts.tar.bz2

Comment 2 YangKun 2007-03-27 03:47:55 UTC
Created attachment 150997 [details]
var-log-hts.tar.bz2

Comment 3 YangKun 2007-03-27 06:25:37 UTC
*** Bug 230244 has been marked as a duplicate of this bug. ***

Comment 4 YangKun 2007-04-16 09:12:10 UTC
fixed in R38

Comment 5 YangKun 2007-04-17 06:12:13 UTC
(In reply to comment #4)
> fixed in R38

no, fixed in R39


Comment 8 Red Hat Bugzilla 2007-08-02 16:30:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0736.html



Note You need to log in before you can comment on or make changes to this bug.