Bug 23419 - Cannot upgrade to version > 4.0.1-0.13
Summary: Cannot upgrade to version > 4.0.1-0.13
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-05 15:45 UTC by Olivier Baudron
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 12:11:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2001-01-05 15:45:05 UTC
When upgrading to any version posterior to 4.0.1-0.13, I get the error
message:

baud:~# rpm -Uvh rpm-4.0.2-0.17.i386.rpm 
Preparing...             ########################################### [100%]
execution of rpm-4.0.2-0.17 script failed, exit status 1

Comment 1 Olivier Baudron 2001-01-06 01:17:08 UTC
The error message message is commented out in the preinstall script:

#    echo "
#You have both
#       /var/lib/rpm/packages.rpm       db1 format installed package headers
#       /var/lib/rpm/Packages           db3 format installed package headers
#Please remove (or at least rename) one of those files, and re-install.
#"

Is there any reason not to display this message?
Btw, I removed /var/lib/rpm/packages and the upgrade worked fine...

Comment 2 Olivier Baudron 2001-01-06 01:18:29 UTC
I meant, I removed /var/lib/rpm/packages.rpm

Comment 3 Jeff Johnson 2001-01-08 15:32:11 UTC
I can't uncomment the message, as Red Hat tries to produce packages that can be
batch
installed, and, by policy, we do not permit any I/O in packages.

Dunno how to fix, I expect  to remove the check for duplicate databases to
become moot
soon after rpm-4.0.1 is released as an errata for all platforms (~2months).
Deferred until then

Comment 4 Jeff Johnson 2001-04-03 12:12:08 UTC
No output is permitted in package scriptlets, so I'm marking WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.